Download it now!
Bug 97113 - Text copy-paste in tables (Draw) behaves strange
Summary: Text copy-paste in tables (Draw) behaves strange
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: ImpressDraw-Tables
  Show dependency treegraph
 
Reported: 2016-01-13 22:20 UTC by Yan Pas
Modified: 2016-06-15 08:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test case that confirms the bug (13.36 KB, application/vnd.oasis.opendocument.graphics)
2016-01-16 18:05 UTC, Otavio Carneiro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yan Pas 2016-01-13 22:20:27 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36
Build Identifier: LibreOffice 5.0.4.2

---

Reproducible: Always

Steps to Reproduce:
1. Paste border, select all cells and specify desirable format (e.g. Arial Bold 12pt)
2. Copy text from one cell to another
3. Pasted text has default format (liberation 18)!!




[Information automatically included from LibreOffice]
Locale: ru
Module: DrawingDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


Reset User Profile?No
Comment 1 Otavio Carneiro 2016-01-16 18:05:56 UTC
Created attachment 122006 [details]
Test case that confirms the bug

Bug confirmation
Comment 2 Otavio Carneiro 2016-01-16 18:08:49 UTC
Bug confirmed on 5.0.4.2 and 5.1.0.2. 

Test case created on 5.1.0.2 is attached.

You have to change the font for the whole table before pasting a cell text in order to see the bug. The font of the pasted text becomes liberation.
Comment 3 Heiko Tietze 2016-06-14 07:28:54 UTC
It seems to work on 5.2. Please double check.
Comment 4 Yan Pas 2016-06-14 16:36:16 UTC
LO master (5.3) reproducible.
Once again:
Insert table
Type some text in 1st cell
Select text, right click, Character.., change size and fonmt family
Paste text to another cell
-> FOrmatting lost
Comment 5 Heiko Tietze 2016-06-14 21:10:04 UTC
(In reply to Yan Pas from comment #4)
> LO master (5.3) reproducible.
> Once again:
> Insert table
> Type some text in 1st cell
> Select text, right click, Character.., change size and fonmt family
> Paste text to another cell
> -> FOrmatting lost

Strange, works for me (Windows 5.2 and Linux 5.1), probably I missed something. What I do is:
1. Insert table in Draw
2. Enter text into first cell (123)
3. Set font size to 14 and bold
4. Copy text and paste it into cell A2 -> bold, 14
5. Use context menu > character to set font color to red
6. Copy and paste into A3 -> Red, 14, bold
Comment 6 Yan Pas 2016-06-14 21:21:00 UTC
I don't know why, but I can't reproduce it now too (both on LO 5.0.5 and master)
Comment 7 Heiko Tietze 2016-06-15 08:14:47 UTC
(In reply to Yan Pas from comment #6)
> I don't know why, but I can't reproduce it now too (both on LO 5.0.5 and
> master)

Perhaps it's somehow related to styles, whether some property was set before or not. But anyway, let us close this bug.

Feel free to reopen when the issue happens again.