Bug Hunting Session
Bug 97138 - page format crash
Summary: page format crash
Status: RESOLVED DUPLICATE of bug 97051
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-14 15:13 UTC by christian.rufener
Modified: 2016-01-19 09:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description christian.rufener 2016-01-14 15:13:59 UTC
Steps to reproduce:

- Start writer
- Use the new document
- Menu: Insert Header -> Default Style
- Save document
- Menu: Format -> Page -> Area -> Fill -> Color (any color)
- Close Document -> LO asks for saving -> Save 
>>> CRASH (Document Recovery)

OS: Windows 7 Enterprise SP-1 (64 bit) 4GB RAM

(Same behavior in 5.0.2.2)
Comment 1 christian.rufener 2016-01-14 15:19:48 UTC
Could reproduce this on MacOSX "El Capitan"
Create 2 documents (in order to observe the crash)
In one of the documents perform the steps analog to the above procedure.
Comment 2 MM 2016-01-14 18:54:07 UTC
Duplicate of bug 97051 ???
Comment 3 Julien Nabet 2016-01-18 21:47:08 UTC
On pc Debian x86-64 with master sources updated 2 days ago, I don't reproduce this but I noticed these messages on console:
warn:sw.core:4013:1:sw/source/core/attr/calbck.cxx:171: a 21SwAccessibleParagraph client added as listener to a 16SwTextFormatColl during client iteration.
warn:sw.core:4013:1:sw/source/core/attr/calbck.cxx:171: a 21SwAccessibleParagraph client added as listener to a 16SwTextFormatColl during client iteration.
warn:sw.core:4013:1:sw/source/core/attr/calbck.cxx:171: a 21SwAccessibleParagraph client added as listener to a 16SwTextFormatColl during client iteration.
warn:sw.core:4013:1:sw/source/core/attr/calbck.cxx:171: a 21SwAccessibleParagraph client added as listener to a 16SwTextFormatColl during client iteration.
warn:legacy.osl:4013:1:sw/source/core/attr/format.cxx:227: SwFormat::~SwFormat: Def dependents!
warn:sw.core:4013:1:sw/source/core/attr/format.cxx:236: ~SwFormat: parent format missing from: Paragraph style
warn:legacy.osl:4013:1:sw/source/core/attr/format.cxx:227: SwFormat::~SwFormat: Def dependents!
warn:sw.core:4013:1:sw/source/core/attr/format.cxx:236: ~SwFormat: parent format missing from: Frameformat
warn:legacy.tools:4013:1:include/svl/poolitem.hxx:219: AddRef with non-Pool-Item
warn:legacy.tools:4013:1:include/svl/poolitem.hxx:219: AddRef with non-Pool-Item
Comment 4 steve -_- 2016-01-19 09:36:02 UTC
this sounds very much like a duplicate indeed. I just reproduced this with master on osx. will add a crashlog to the original report and set this to dupe.

*** This bug has been marked as a duplicate of bug 97051 ***