Bug Hunting Session
Bug 97158 - EDITING - copy paste row on multiple sheets
Summary: EDITING - copy paste row on multiple sheets
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Eike Rathke
URL:
Whiteboard: target:5.3.0 target:5.2.0.1 target:5.1.4
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-01-15 21:06 UTC by James B. Byrne
Modified: 2016-10-25 18:54 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James B. Byrne 2016-01-15 21:06:07 UTC
Given a spreadsheet with multiple sheets.  When multiple sheets are simultaneously selected then copying a row and pasting it enters the topmost row values into all of the selected sheets.  In version LO4.3 and previous the behaviour of the row copy function on multiple selected sheets was to select the corresponding row from each selected sheet and paste that row into the corresponding sheet.

For example: Given two sheets: SA and SB; where both sheets contain a row 11 with a cell A11 where each cell has the respective values: SA:A11=31 and SB:A11=55; and we perform all of the following actions while both sheets remain selected; and we select row 11 on SA; and we insert a new row at SA:11; and we copy row SA:12, having the contents of the former row SA:11; and we paste that copied row into row SA:11; then the following is observed:

SA:A11=31;
SA:A12=31; 
and
SB:A11=31;    <== this is not the expected or prior behaviour
SB:A12=55.  

The expected result is:

SA:A11=31;
SA:A12=31; 
and
SB:A11=55;
SB:A12=55.

This issue does not occur in OpenOffice-4.1.2 or earlier.
Comment 1 Buovjaga 2016-01-21 14:41:29 UTC
I confirm, but is this an intentional decision?

(In reply to James B. Byrne from comment #0)
> This issue does not occur in OpenOffice-4.1.2 or earlier.

This is not relevant :)

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 6b65a0e83c4798f117be61af91dbaebdc85e94b7
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-01-21_03:41:08
Locale: fi-FI (fi_FI)
Comment 2 Buovjaga 2016-03-10 11:44:21 UTC
Well let's set to NEW.
Comment 3 u81 2016-03-10 12:37:02 UTC
I confirm - The feature works as intended in version 4.2.8 as well but not since then.

I fix for the latest version 5.1 would definitely be a big blessing
Comment 4 raal 2016-04-08 06:28:22 UTC
(In reply to u81 from comment #3)
> I confirm - The feature works as intended in version 4.2.8 as well but not
> since then.
> 
Changing version.
Comment 5 Eike Rathke 2016-05-30 16:10:23 UTC
Note: inserting a row is an irrelevant step.
Comment 6 Commit Notification 2016-05-30 16:34:36 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dc9eac5a5f4f247ba5efb67931ffde61f2c8d5b6

Resolves: tdf#97158 CopyOneCellFromClip() does not handle multiple sheets

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2016-05-30 17:14:33 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=800920a7b0600b1677d231c514345fe9f6687d82&h=libreoffice-5-2

Resolves: tdf#97158 CopyOneCellFromClip() does not handle multiple sheets

It will be available in 5.2.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2016-05-30 18:20:33 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9d07f557572bdeaeda8e923525c8895d79fc0d22

actually multiple destination sheets are handled, tdf#97158 follow-up

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2016-05-30 18:54:37 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dd38581b787f357ee88da7dfabeb596a894b5afe&h=libreoffice-5-2

actually multiple destination sheets are handled, tdf#97158 follow-up

It will be available in 5.2.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Eike Rathke 2016-05-30 20:34:47 UTC
Pending review https://gerrit.libreoffice.org/25682 for 5-1
Comment 11 Commit Notification 2016-05-31 09:48:58 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5e99baf433a3e3d372979cc74240de5c93f71319&h=libreoffice-5-1

Resolves: tdf#97158 CopyOneCellFromClip() does not handle multiple sheets

It will be available in 5.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 u81 2016-06-22 14:38:50 UTC
Thank you very much Eike Rathke for the patch.

I've just tested it in 5.1.4 and it does work i.e. - copy the same cell in multiple sheets and paste it to the same number of sheets in another file.

However, the statusbar sum function still only shows the sum of the cells selected on the current sheet even though you multiple sheets selected.

Any help on that issue would be much appreciated.

Thanks once again for your time and valuable contribution.