Bug 97162 - Problem customising toolbars
Summary: Problem customising toolbars
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: corruptProfile
Keywords:
Depends on:
Blocks: User-Profile
  Show dependency treegraph
 
Reported: 2016-01-15 23:55 UTC by Tim Chambers
Modified: 2017-06-25 23:00 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Chambers 2016-01-15 23:55:20 UTC
User-Agent:       Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36
Build Identifier: LibreOffice 5.0.4.2

I had an issue where I could only customise toolbars if I was saving them to the current document. If I was trying to save the customisation to LibreOffice ticking the boxes in the customisaiton options had no effect.

I have tracked down the problem. My user profile C:\Users\USERNAME\AppData\Roaming\LibreOffice\4\user\
did not have a config folder.

Once I created the config folder the problem was resolved.

I do not know why the config folder was missing, or why LO did not create the folder when required.

Cheers



Reproducible: Always




[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no


Reset User Profile?Yes
Comment 1 Jean-Baptiste Faure 2016-01-16 22:05:35 UTC
Perhaps the config subdirectory was missing because of a profile corruption, I do not know.
If you rename your current user profile, LO will create a new one. Does this new profile have a config subdirectory? It is the case for me with LO 5.0.

Best regards. JBF
Comment 2 Jean-Baptiste Faure 2016-01-17 17:59:41 UTC
Set status to NEEDINFO due to comment #1

Best regards. JBF
Comment 3 Tim Chambers 2016-01-17 23:33:07 UTC
I tested by renaming the user profile and starting LO.

It did create the config folder in the new user settings so no problem there.

Not sure what happened for me to lose the config folder in the first place.

Thanks fro your help
Comment 4 Jean-Baptiste Faure 2016-01-18 05:20:57 UTC
Thank you for your answer. I think we can close this bug report as WorksForMe.
Please, feel free to reopen if it comes back and you can identify the event which remove the config subdirectory from the user profile.

Best regards. JBF