Bug 97221 - Unhelpful error message for 'check for updates'
Summary: Unhelpful error message for 'check for updates'
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Adolfo Jayme
URL:
Whiteboard: target:5.2.0
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-18 08:45 UTC by Bob Harvey
Modified: 2016-10-25 19:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
result of 'check for updates' (27.25 KB, image/jpeg)
2016-01-18 08:45 UTC, Bob Harvey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Harvey 2016-01-18 08:45:14 UTC
Created attachment 122053 [details]
result of 'check for updates'

OK, I am on Windows 10 1511, and LibreOffice 5.0.4.2

When I run "check for updates" it doesn't work, but the resultant dialogue is not terribly helpful.  It just says "Checking for an update failed".

It does not say "cannot contact server" or give any clue as to what it is trying to do.  It doesn't say "no internet connection" (there is, I am making a bug report).  It gives me no clue as to whether the problem is my end or yours, or any way to go further.

The same thing happens in Write and Calc and Draw.  I think that is enough examples
Comment 1 Christian Lohmaier 2016-01-21 15:38:35 UTC
server was suffering a misconfiguration, so replied with "garbage" instead of update-check result, so "couldn't understand the update server's response" would be the actual message for this case.

I don't think it is worth doing a detailed check for this (unlikely) condition though, thus closing works for me.

(IIRC there is dedicated message in case the server is not reachable/times out)
Comment 2 Commit Notification 2016-01-23 05:51:49 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ded9e554d470b5a2c7238f5b61effada08ecef39

tdf#97221 Improve this error message a bit…

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Stanislav Horacek 2016-01-23 17:20:39 UTC
I don't think the committed change is a solution because the message appears also when there is no internet connection. In that case, the changed message can be very misleading and I would suggest to revert the change.
Comment 4 Stanislav Horacek 2016-05-20 15:59:30 UTC
The revert suggestion sent to Gerrit:
https://gerrit.libreoffice.org/#/c/25217/
Comment 5 Commit Notification 2016-05-21 06:53:02 UTC
Stanislav Horacek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fcec7522c15c9c7c70244320b8e21380498322ec

tdf#97221 restore original message for failed check of update

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.