Bug 97229 - Tables are split after saving as .doc
Summary: Tables are split after saving as .doc
Status: RESOLVED DUPLICATE of bug 91083
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.3.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: filter:doc
Depends on:
Blocks:
 
Reported: 2016-01-18 14:02 UTC by Nicolas Mailhot
Modified: 2016-08-23 13:22 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Testcase (46.70 KB, application/vnd.oasis.opendocument.text)
2016-01-18 14:02 UTC, Nicolas Mailhot
Details
Simplified test document (30.42 KB, application/vnd.oasis.opendocument.text)
2016-06-15 10:11 UTC, lorenzo.morin
Details
Doc file created with LibreOffice 5.1.3.2 (25.24 KB, application/msword)
2016-06-15 10:12 UTC, lorenzo.morin
Details
Screenshot with MSO (33.35 KB, image/png)
2016-06-15 10:15 UTC, lorenzo.morin
Details
Screenshot with LibreOffice (24.43 KB, image/png)
2016-06-15 10:17 UTC, lorenzo.morin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Mailhot 2016-01-18 14:02:28 UTC
Created attachment 122058 [details]
Testcase

The attached testcase, where splitting tables is forbidden, does not preserve this property once saved as .doc and opened in Microsoft Word 97
Comment 1 raal 2016-01-20 19:28:36 UTC
Where can I see this parameter in Microsoft Word? Can you post a printscreen?
Comment 2 Nicolas Mailhot 2016-01-21 13:35:51 UTC
1. open the file in LOO : no table is split on multiple pages
2. save as .doc
3. open the result in Word 97 : tables are split on multiple pages
Comment 3 raal 2016-01-21 14:23:55 UTC
Needs to be confirmed to status NEW. Post a printscreen, I doesn't see thin in word 2003.
Comment 4 Nicolas Mailhot 2016-01-21 14:42:32 UTC
It has already been confirmed, you can check in the ticket history.
Comment 5 raal 2016-01-21 14:54:26 UTC
You can not confirm your own bugs.
Comment 6 Cor Nouws 2016-01-21 15:05:43 UTC
(In reply to Nicolas Mailhot from comment #2)

> 3. open the result in Word 97 : tables are split on multiple pages

And for people that want to test and do not have Word 97: do yo have any idea how it looks in 2003 / XP / 2007 / 2010 / 2013 ... ?
Comment 7 Nicolas Mailhot 2016-01-21 19:08:14 UTC
(In reply to Cor Nouws from comment #6)
> (In reply to Nicolas Mailhot from comment #2)
> 
> > 3. open the result in Word 97 : tables are split on multiple pages
> 
> And for people that want to test and do not have Word 97: do yo have any
> idea how it looks in 2003 / XP / 2007 / 2010 / 2013 ... ?

Sorry I meant to write Word 2007, which is the only version I have access to
Comment 8 Buovjaga 2016-02-04 16:47:21 UTC
Unable to locate split tables. I also tried to make them split by inputting empty lines, but tables just jumped to the next page and DID NOT split.

Again, plz attach screenshot of the problem.

There is something different in the layout, however, as in LibO, page count is 16, but in word it is 17.

Win 8.1 32-bit
MSO 2013
LibO Version: 5.2.0.0.alpha0+
Build ID: 27a114e73f9ce64f360b045233e1c9c74c207880
CPU Threads: 4; OS Version: Windows 6.29; UI Render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-02-04_09:04:40
Locale: fi-FI (fi_FI)
Comment 9 lorenzo.morin 2016-06-15 10:11:00 UTC
Created attachment 125667 [details]
Simplified test document

Simplified odt test file
Comment 10 lorenzo.morin 2016-06-15 10:12:17 UTC
Created attachment 125668 [details]
Doc file created with LibreOffice 5.1.3.2

Doc file created with LibreOffice 5.1.3.2
Comment 11 lorenzo.morin 2016-06-15 10:14:25 UTC
The tables are splitted when the file is opened with MSO.
Comment 12 lorenzo.morin 2016-06-15 10:15:32 UTC
Created attachment 125669 [details]
Screenshot with MSO

Screenshot of the doc file opened with MSO
Comment 13 lorenzo.morin 2016-06-15 10:17:50 UTC
Created attachment 125670 [details]
Screenshot with LibreOffice

Screenshot of the file opened with LibreOffice
Comment 14 lorenzo.morin 2016-06-15 10:20:24 UTC
(In reply to lorenzo.morin from comment #11)
> The tables are splitted when the file is opened with MSO.

Confirmed on:
Office 365
Version: 16.0.6965.2053
OS: Windows 7 Home Premium SP1 x86

Simplified test file created with:
LibreOffice Version: 5.1.3.2
Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: it-IT (it_IT)
Comment 15 Alex Thurgood 2016-08-18 08:08:26 UTC
This looks like a DUP of bug 62613, setting as such.

*** This bug has been marked as a duplicate of bug 62613 ***
Comment 16 Nicolas Mailhot 2016-08-18 12:08:09 UTC
It has nothing to do with bug #62613, bug #62613 concerns not honouring a word setting to split table lines when importing in LO, this bug is about not honouring a setting forbidding to split lines when exporting from LO
Comment 17 Justin L 2016-08-23 13:19:21 UTC
I believe that Word does not have an option to prevent a table from splitting. 

So, LibreOffice needed to emulate that behaviour, which was re-implmeented in 5.2.  The SETTING table->textFlow.allow-table-to-split-across-rows-and-columns is not preserved (instead, each row is set to keep with next), but the LAYOUT effect is the same.

duplicate of bug 91083 - fixed in 5.2 for .doc and .docx.

A remaining enhancement could be recognizing the emulation on import, removing the keep-with-next-row setting, and disabling allow-table-to-split.

*** This bug has been marked as a duplicate of bug 91083 ***