Bug 97238 - OpenCL: functions returns wrong data in big worksheet
Summary: OpenCL: functions returns wrong data in big worksheet
Status: RESOLVED DUPLICATE of bug 94924
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: OpenCL
  Show dependency treegraph
 
Reported: 2016-01-18 21:03 UTC by Martin Roth
Modified: 2016-01-29 09:47 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Summary of Expenditures (12.96 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-01-18 21:03 UTC, Martin Roth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Roth 2016-01-18 21:03:07 UTC
Created attachment 122063 [details]
Summary of Expenditures

When you open file, you can see what is about. Check the cell with the formula. If the entry is empty cell, the formula is evaluated incorrectly. This error began to show in the old workbook after upgrade LibreOffice.
I am sorry for my English.
Comment 1 Jean-Baptiste Faure 2016-01-18 21:31:47 UTC
Select all (ctrl+A) and do an hard recalculation (ctrl+shift+F9).

Closing as WorksForMe. Feel free to reopen if you disagree.

Best regards. JBF
Comment 2 Eike Rathke 2016-01-18 22:03:26 UTC
Ctrl+A isn't needed for hard recalc, Shift+Ctrl+F9 is sufficient. Recalc cures the symptom, but it would be interesting to know how this document state sprang into existence..

The document apparently was saved without being recalculated, however that may have happened, it might be that AutoCalculate was off when modifying the document and then switched on before saving but without actually having recalculated. Was that the case? Did you delete/empty cells in the colored columns while AutoCalculate was off?

Current versions don't recalculate documents when loading.

If you have more than this document in such state you may want to enable Tools->Options->Calc->Formula "Recalculation on File Load" for ODF spreadsheet.
Comment 3 Martin Roth 2016-01-19 09:02:00 UTC
I know hard recalc, but it isn't solve of problem. Columns with formulas in this workbook are usually hidden and user have spotted only bad values in summary (after upgrade Libreoffice). Autocalculate was always on. After use hard recalc, this error happened again after some time. May be resolving is set "Recalculation on File Load", but how is it possible that it happens? Origin of this workbook is about 2 years old and till the version 4.4.7.2 worked properly.
Comment 4 Martin Roth 2016-01-19 13:51:24 UTC
I have found that hard recalc, even settings "Recalculation on File Load" doesn't work only in user's notebook. When I completly fixed workbook (in my PC) and user after that open it in his notebook - bad cells still there were, but not all. Interesting. If the file without errors is opened at this notebook, bug appears again and again immediately after open.
ASUS, Windows 7 Home Premium 64bit, SP1; AMD A4-3300M, RAM 6GB.
Comment 5 Eike Rathke 2016-01-19 15:40:16 UTC
(In reply to Martin from comment #4)
> doesn't work only in user's notebook. When I completly fixed workbook (in my
> PC) and user after that open it in his notebook - bad cells still there
> were, but not all. Interesting. If the file without errors is opened at this
> notebook, bug appears again and again immediately after open.
> ASUS, Windows 7 Home Premium 64bit, SP1; AMD A4-3300M, RAM 6GB.

And what program and which version does that user use to open the file?
Comment 6 Martin Roth 2016-01-19 15:58:22 UTC
User using version as i wrote 4.4.7.2
I have installed today the same version on my PC, and everything works properly. That's why i don't understand why it do this error in the same release on the other computer.
Comment 7 Oliver Brinzing 2016-01-19 17:24:26 UTC
> I have installed today the same version on my PC, and everything works properly. 
> That's why i don't understand why it do this error in the same release 
> on the other computer.

Maybe an OpenCL bug (for example: https://bugs.documentfoundation.org/show_bug.cgi?id=97150)

Does it work if you to disable OpenCL?
Comment 8 Martin Roth 2016-01-19 17:56:54 UTC
(In reply to Oliver Brinzing from comment #7)

> Maybe an OpenCL bug (for example:
> https://bugs.documentfoundation.org/show_bug.cgi?id=97150)
> 
> Does it work if you to disable OpenCL?

Yes, it does. Disabling OpenCL solves the issue.

Origin worksheet contain many rows (more the 1000) with formulas and enabling OpenCL causes incorrectly evaluated formulas in some types of computer.

Thank you for help.
One more time i must to sorry for my english.
Comment 9 Eike Rathke 2016-01-26 23:05:11 UTC
@mmeeks:
This is yet another "calculating wrong with OpenCL" report.
Any estimate if, how and in what time frame it can be fixed on your side?
As an interim measure I suggest to default the OpenCL option to disabled
in all releases.
Comment 10 Tor Lillqvist 2016-01-27 06:24:02 UTC
So in which version is the bug present? The bug reporter tells that in 4.4.7 LibreOffice works correctly, unless I am mistaken. So the Version field is likely wrong?
Comment 11 Tor Lillqvist 2016-01-27 06:26:21 UTC
Ah, re-reading, so he does see an error in 4.4.7 on some machine(s). Ignore my previous comment.
Comment 12 Tor Lillqvist 2016-01-27 06:49:14 UTC
Anyway, this sounds a lot like a problem that was fixed in 5.0. Duplicate of bug #94924?
Comment 13 Tor Lillqvist 2016-01-29 09:47:04 UTC
The incorrect data disappears when one does a hard recalc (Ctrl+Shift+F9) in a LibreOffice version that contains a fix for this bug (i.e., earlier duplicate bug reports). For instance 5.0.3.2.

*** This bug has been marked as a duplicate of bug 94924 ***