Bug 97245 - Format Paintbrush issues
Summary: Format Paintbrush issues
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Clear-Formatting
  Show dependency treegraph
 
Reported: 2016-01-19 05:57 UTC by Jim Avera
Modified: 2018-01-14 15:26 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Demo file, including instructions (20.43 KB, application/vnd.oasis.opendocument.text)
2016-01-19 05:57 UTC, Jim Avera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2016-01-19 05:57:29 UTC
Created attachment 122072 [details]
Demo file, including instructions

Certain paragraphs seem immune to having their paragraph or character styles changed using the Format Paintbrush.  

I will attach a demo document which has several paragraphs with 
  Before text: 0.30"
  After text: 0
  First line: -0.30"

Copying Paragraph format (Control-click) from another para with all zeroes does not change the destination paragraph, i.e. the indents in the paragraph do not change to zeroes.   Also, copying Character format from unadorned text into text which has a colored Character format doesn't change the destination.  

"Clear Direct Formatting" doesn't have any visible effect, so it's not direct formats that are overriding.

Please see the demo file, which includes specific instructions to reproduce.


Version: 5.0.2.2
Build ID: 00m0(Build:2)
Locale: en-US (en_US.UTF-8)
Comment 1 Buovjaga 2016-01-25 12:13:07 UTC
Repro.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 6b65a0e83c4798f117be61af91dbaebdc85e94b7
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-01-21_03:41:08
Locale: fi-FI (fi_FI)
Comment 2 Telesto 2017-01-28 17:58:13 UTC
Confirming with
Version: 5.4.0.0.alpha0+
Build ID: b41186a2fc49e440890b8c86e5367352ffaf9cd6
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-26_01:50:40
Locale: nl-NL (nl_NL); Calc: CL

and with:
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 3 Buovjaga 2018-01-14 15:26:39 UTC
This seems to be a case of "hidden mysteries": the problematic paragraphs are in fact list items! I unzipped the .odt and edited the content.xml. I made one of the indented paragraphs to not be a list item like so:

<text:p text:style-name="P1">blah blah blah blah blah blah blah [blah blah] blah blah blah blah blah blah blah blah@blah.blah (blah blah blah blah blah blah blah blah blah).</text:p>

Then I re-zipped the files and renamed back to .odt. I opened the file and there was no indent to begin with. So the indent comes from the list style and the format paintbrush has no power over it.

Let's close.