Bug 97253 - Cell function lost when copying chart from Calc to Impress
Summary: Cell function lost when copying chart from Calc to Impress
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-Function Cut-Copy
  Show dependency treegraph
 
Reported: 2016-01-19 16:32 UTC by Walter Cheuk
Modified: 2018-02-19 20:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
demo.ods (13.22 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-01-19 16:32 UTC, Walter Cheuk
Details
demo.odp (14.94 KB, application/vnd.oasis.opendocument.presentation)
2016-01-19 16:33 UTC, Walter Cheuk
Details
msoffice.odp (36.89 KB, application/vnd.oasis.opendocument.presentation)
2016-01-19 16:33 UTC, Walter Cheuk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Walter Cheuk 2016-01-19 16:32:55 UTC
Created attachment 122086 [details]
demo.ods

Create a chart in Calc, where some cells contain function ( =sum(), in particular, please see attached "demo.ods"). Copy that chart and paste in Impress; observe that all cell functions are lost, only the calculated results remain (please see attached "demo.odp"). If the same thing is done in Excel and Powerpoint, all the cell functions remain. In fact LO can handle that kind of file quite well (please see attached "msoffice.odp", I open the result .ppt in Impress and save it to .odp).
Comment 1 Walter Cheuk 2016-01-19 16:33:32 UTC
Created attachment 122087 [details]
demo.odp
Comment 2 Walter Cheuk 2016-01-19 16:33:59 UTC
Created attachment 122088 [details]
msoffice.odp
Comment 3 raal 2016-01-19 18:20:17 UTC
Hello,
you mean in Menu Insert->Object-> Ole object -> spreadsheet?

https://help.libreoffice.org/Common/Insert_OLE_Object
Comment 4 Walter Cheuk 2016-01-20 00:52:56 UTC
No. Just the most simple 'copy and paste' action: right click the chart in Calc, and then right click in Impress and 'paste'.
Comment 5 Walter Cheuk 2016-01-20 01:14:27 UTC
The chart copied to Impress is not an 'inserted spreadsheet object' like your mentioned method does. Please compare 'demo.odp' and 'msoffice.odp'.
Comment 6 raal 2016-01-20 08:55:47 UTC
Copy/paste is not the same as insert OLE object. If you want the result of copy/paste action should be as insert OLE object, then it's not a bug, maybe enhancement, but for me I doesn't see why this should be changed. The result you can obtain with Insert->Object-> Ole object -> spreadsheet. Maybe I misunderstood..
Comment 7 Walter Cheuk 2016-01-21 03:07:17 UTC
If I need all the functionalities of the original chart, why can't I do it in a simple 'copy & paste' action? Also there is no easy way to create chart from the data of an inserted spreadsheet (I can't find it yet).
Comment 8 Walter Cheuk 2016-01-21 08:09:02 UTC
Users don't expect to lose some functionalities when they do a 'copy & paste' across applications, especially when LO is advertised as a tightly-integrated suite. If someone do need a simple chart only (I don't know what exact kind of object the chart is), they may use 'paste...' to paste a trimmed-down version of the chart.
Comment 9 Buovjaga 2016-01-26 12:30:46 UTC
(In reply to Walter Cheuk from comment #8)
> Users don't expect to lose some functionalities when they do a 'copy &
> paste' across applications, especially when LO is advertised as a
> tightly-integrated suite. If someone do need a simple chart only (I don't
> know what exact kind of object the chart is), they may use 'paste...' to
> paste a trimmed-down version of the chart.

Does Microsoft Office behave like you wish LibO would do?
Comment 10 Walter Cheuk 2016-01-26 15:30:05 UTC
yes
Comment 11 Jean-Baptiste Faure 2018-02-19 20:56:01 UTC
I agree with raal. Copy and paste of chart behaves as designed, so closing as NotABug.
If you want propose a change in this behavior, please fill an enhancement request. Do not miss to explain in what way this enhancement is a good thing and will make the LO users life easier.

Best regards. JBF