Bug Hunting Session
Bug 97266 - Calc goes too far selecting range in chart
Summary: Calc goes too far selecting range in chart
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Chart
  Show dependency treegraph
 
Reported: 2016-01-20 03:13 UTC by rodhos92
Modified: 2018-05-25 08:11 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
example file to reproduce bug (15.07 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-01-20 03:13 UTC, rodhos92
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rodhos92 2016-01-20 03:13:09 UTC
Created attachment 122108 [details]
example file to reproduce bug

1. Open a Spreadsheet with random data in it.
2. Click the Chart button to plot the data.
3. Click in finish
4. Right click inside the chart area and select: Data Ranges
5. Select the "Data series" tab.
6. Select one of the "Data Ranges:" options like "Y-Values" or "X-Values".
7. If you selected "Y-Values", behind "Data Ranges:" you will find "Range for Y-Values" entry. Click the button with an arrow pointing upwards you will find in the right.
8. A little window shows up. Click and drag the cursor over the data to select it. Now the data is surrounded by a purple square.
9. Continue dragging the cursor to the bottom for a few seconds.
10. When you stop, the selected area keeps going down for several minutes reaching the row number 10000 or so. During that time you can not close the window nor the program. You can only kill the program resulting in data loss or wait 15 minutes for the program to stop loosing valuable working time.

What do I spect: When I stop dragging the cursor the program stop in selecting rows.

What happens: The program keeps going on selecting rows for several minutes without the posibility of saving the work or closing the program.
Comment 1 raal 2016-01-21 12:26:31 UTC
I can not confirm on win7 Version: 5.2.0.0.alpha0+
Build ID: f4e703aa39e9c294441b6dd86189d8aff32db8bf
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default;
Comment 2 Terrence Enger 2016-01-22 02:32:32 UTC
I see the reported problem in daily dbgutil bibisect repo version
2016-01-20, so setting status NEW.  The problem is absent from
bibisect 43all repository oldest version, so setting keyword
regression.

Some observations ...

(*) The uncontrolled looping happens only when I drag the mouse cursor
    down to at least the task bar.

(*) The selection grows faster as I drag the mouse cursor lower.

(*) While the uncontrolled loop is in progress, I can move the mouse
    cursor but I have found nothing that responds to clicks, the
    desktop responds normally to the keyboard, and soffice is using 95
    to 99 percent of a processor.

(*) In some versions of LibreOffice, I cannot access the "Data Series"
    tab of the dialog "Data Ranges" the first time that example.ods is
    open.  If I close the document (discarding changes) and then
    reopen it from the Start Center, I can follow the rest of the
    reporter's STR.


Working in the bibisect 50max repository, I see from `git bisect bad` ...

    18afb8632caa524fbc70ed5ce3808e23e5dad16f
    # only skipped commits left to test
    # possible first bad commit: [18afb8632caa524fbc70ed5ce3808e23e5dad16f] source-hash-d05a64df34fd143670cb939b72abfb32d6b714c7
    # possible first bad commit: [891b689ba95b9e53609194ee2a1a2d3b8955843c] source-hash-01f406bc28f53acc5a2734af637aa8074a5d1813

... so setting keyword bibisected.  I am omitting the output from `git bisect
log` because I accumulated a great number of "skip" results before I
found the workaround to get to the "Data Series" tab.
Comment 3 Markus Mohrhard 2016-02-03 22:46:17 UTC
Might have been an issue with the idle handling. Can you try again in master/5.2? I can't reproduce this issue in current master.
Comment 4 Terrence Enger 2016-04-03 02:09:11 UTC
In my retest, the program does not crash, but it is still wrong.  I am
changing summary from "CRASH: Calc hangs when selecting data ranges in
chart" to "Calc goes too far selecting range in chart".

This observations is from daily Linux dbgutil bibisect repository
version 2016-04-02.

As I moved the dragging cursor down, the selection appeared to stop at
A83.  However the program continued for a couple of minutes of high
CPU usage, and then the selection was from A1 to A3251.
Comment 5 QA Administrators 2017-05-22 13:20:22 UTC Comment hidden (obsolete)
Comment 6 rodhos92 2017-05-22 16:53:50 UTC
I tested again in Ubuntu 16.10 and LibreOffice 5.3.3.2
I used a more powerfull machine and the system blocks completely. I needed to close the program in a virtual terminal.

1st I tested selecting data. With mouse cursor at very bottom the program enters in a loop as @Terrence Enger said.

2nd I tested with "Data Ranges" thing and OS completely froze.

I will try to test in Windows.
Comment 7 rodhos92 2017-05-22 17:44:11 UTC
The bug in not present in Windows 10 but in Ubuntu 14.04 and 16.10 as far as I know.
Comment 8 Buovjaga 2018-05-24 18:10:34 UTC
Tried with gtk2, gtk3 and kde4, but could not reproduce any scrolling problem. Please re-test and hopefully close this.

Arch Linux 64-bit
Version: 6.1.0.0.alpha1+
Build ID: eeaf6dee2d278eaa037d95a756ad0ffab3314bc2
CPU threads: 8; OS: Linux 4.16; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on May 24th 2018
Comment 9 rodhos92 2018-05-25 08:09:40 UTC
Retested in Ubuntu 18.04 and LibreOffice 6.0.3.2
I can't reproduce the bug anymore. It seems fixed for me.