Download it now!
Bug 97274 - Frames borders are not correctly exported in .docx format (for Word<=2007)
Summary: Frames borders are not correctly exported in .docx format (for Word<=2007)
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Frames DOCX
  Show dependency treegraph
 
Reported: 2016-01-20 12:28 UTC by Frederic Parrenin
Modified: 2019-07-20 02:46 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
.odt file to reproduce the problem (267.67 KB, application/vnd.oasis.opendocument.text)
2016-01-20 12:28 UTC, Frederic Parrenin
Details
printscreen (123.87 KB, image/png)
2016-01-20 18:15 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Parrenin 2016-01-20 12:28:39 UTC
Created attachment 122115 [details]
.odt file to reproduce the problem

Steps to reproduce:
- open the attached .odt files
- remark that the frames inside have no border
- save to .docx format
- open the .docx file in Word
=> now the frames have a border
Comment 1 raal 2016-01-20 18:15:57 UTC
Created attachment 122119 [details]
printscreen

Hello, 
seems to be fixed in dev version. Please could you test with dev version?
http://dev-builds.libreoffice.org/daily/master/
Thank you


Version: 5.2.0.0.alpha0+
Build ID: d95d9d7f908419f397941ef60ac6ced3261c9b87
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-01-19_00:40:21
Comment 2 Buovjaga 2016-01-25 13:06:14 UTC
Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 3 Frederic Parrenin 2016-01-26 16:59:12 UTC
This problem is still present in LO 5.2alpha (build of 2016/01/25).
Actually, it depends on the version of word one is using.
It shows up with word 2007, but not with more recent versions.
Comment 4 Buovjaga 2016-02-04 16:41:35 UTC
Yep, it is true that in MSO 2013 the problem is not present.

Win 8.1 32-bit
MSO 2013
LibO Version: 5.2.0.0.alpha0+
Build ID: 27a114e73f9ce64f360b045233e1c9c74c207880
CPU Threads: 4; OS Version: Windows 6.29; UI Render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-02-04_09:04:40
Locale: fi-FI (fi_FI)
Comment 5 QA Administrators 2018-07-19 02:41:18 UTC Comment hidden (obsolete)
Comment 6 Frederic Parrenin 2018-07-19 07:20:32 UTC
I currently do not have a version of Word 2007 to test this problem.
Comment 7 QA Administrators 2019-07-20 02:46:51 UTC
Dear Frederic Parrenin,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug