Bug Hunting Session
Bug 97293 - UI hangs when showing print dialog with unreachable IPP printer (CUPS)
Summary: UI hangs when showing print dialog with unreachable IPP printer (CUPS)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: All Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Print-Dialog Network
  Show dependency treegraph
 
Reported: 2016-01-21 10:09 UTC by Felipe Borges
Modified: 2019-11-11 13:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felipe Borges 2016-01-21 10:09:25 UTC
If I add an unreachable CUPS server to my /etc/cups/client.conf and try to open the Print Dialog on LibreOffice, it freezes the whole UI.

Suggestion: the CUPS request for printers (cupsGetDests or http request) should be done in another thread.

How to reproduce:
1. Open /etc/cups/client.conf
2. Append "ServerName cups.nikhef.nl" (with no quotes), and save.
3. Open any LibreOffice application and try to print something.

Actual results:
UI freezes

Expected results:
Print Dialog to show.
Comment 1 Buovjaga 2016-01-26 13:06:59 UTC
Repro, but not in 5.0.4.

Felipe: what version did you try with?

Ubuntu 15.10 64-bit 
Version: 5.0.4.2
Build ID: 1:5.0.4~rc2-0ubuntu1~wily1
Locale: en-US (en_US.UTF-8)

Version: 5.2.0.0.alpha0+
Build ID: c43fdd74097cb12f69f86fd1217dd2f41ccae101
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF-dbg, Branch:master, Time: 2016-01-25_23:43:01
Locale: en-US (en_US.UTF-8)
Comment 2 Felipe Borges 2016-01-26 13:46:35 UTC
Fedora 23 64bits
Version: 5.0.4.2
Build ID: 5.0.4.2-3.fc23

version packaged on Fedora 23.
Comment 3 Buovjaga 2016-01-26 13:56:41 UTC
Strange.. it only hangs for me in 5.2.
Comment 4 RafaU 2018-01-08 10:40:33 UTC
The issue with "ghost" printer has a serious impact on the "styles and formatting" window (and "format->character" etc.), which freezes for about 5-10 seconds.

Wersja: 5.4.4.2
Build ID: 1:5.4.4~rc2-0ubuntu0.16.04.1~lo1
CPU threads: 4; OS: Linux 4.10; UI render: domyślny; VCL: gtk3; 
Ustawienia regionalne: pl-PL (pl_PL.UTF-8); Calc: group

Description:	Ubuntu 16.04.3 LTS
Comment 5 QA Administrators 2019-01-09 03:45:09 UTC Comment hidden (obsolete)
Comment 6 Michael Weghorn 2019-11-08 23:59:46 UTC
Is this still an issue with CUPS >= 2.2.7?

I can't recall the details at the moment, but I remember that something has changed in CUPS that made us drop the idea of doing something similar for the Qt print dialog, s. https://codereview.qt-project.org/c/qt/qtbase/+/225198/ , in particular the last comment there:

> Abandoning this patchset since it is quite complex (threads & stuff) and the
> kind of printers it supports are no longer available on CUPS 2.2.7 so we've 
> decided to not increase the complexity of the code to support "old" printer 
> configurations.

If this is no longer an issue with current CUPS versions, I suggest to close this bug as WORKSFORME as well.
Comment 7 Felipe Borges 2019-11-11 13:20:36 UTC
I tested now with newer cups (2.2.12) and libreoffice (6.3.3.2), and it works as expected.
Comment 8 Michael Weghorn 2019-11-11 13:46:33 UTC
(In reply to Felipe Borges from comment #7)
> I tested now with newer cups (2.2.12) and libreoffice (6.3.3.2), and it
> works as expected.

Thanks for testing!