Download it now!
Bug 97332 - SVG: Incorrect fill color
Summary: SVG: Incorrect fill color
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, filter:svg, regression
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2016-01-23 00:27 UTC by Xisco Faulí
Modified: 2016-03-08 21:32 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file (47.64 KB, image/svg+xml)
2016-01-23 00:27 UTC, Xisco Faulí
Details
comparison with FF (145.70 KB, image/png)
2016-01-23 18:51 UTC, raal
Details
how it looks for me (70.45 KB, image/png)
2016-01-23 20:06 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-01-23 00:27:41 UTC
Created attachment 122167 [details]
Sample file

Steps to reproduce:
1. Insert attached file from Insert -> Image
2. Compare results with previous versions of libreoffice or firefox/chrome
Comment 1 raal 2016-01-23 18:51:22 UTC
Created attachment 122175 [details]
comparison with FF

I can not confirm with Version: 5.2.0.0.alpha0+
Build ID: e1367aaf7d9cc93bbbe3ba64015fde3469c61c6e
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-01-20_23:32:01
Comment 2 Xisco Faulí 2016-01-23 20:06:40 UTC
Created attachment 122176 [details]
how it looks for me
Comment 3 Buovjaga 2016-01-28 15:55:14 UTC
Looks fine here as well inserted.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 259c1ed201f4277d74dfd600fed8c837cbf56abc
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-01-27_00:45:12
Locale: fi-FI (fi_FI)
Comment 4 Yousuf Philips (jay) (retired) 2016-02-03 21:21:06 UTC
Not able to reproduce on Linux Mint 17.3 Mate.

Version: 5.2.0.0.alpha0+
Build ID: 513d5c5781ec14f8512432f31290a3d54c8d57df
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-01_10:25:20
Locale: en-US (en_US.UTF-8)

Might be some underlying library on your system that LO is relying on. What version of Ubuntu are you running?
Comment 5 Keith Curtis 2016-03-05 04:52:18 UTC
If I do Insert - Image then it looks okay, but if I do file-open then I see the problem.
Comment 6 Yousuf Philips (jay) (retired) 2016-03-05 05:49:54 UTC
(In reply to Keith Curtis from comment #5)
> If I do Insert - Image then it looks okay, but if I do file-open then I see
> the problem.

This is a Insert > Image bug not a File > Open bug.

@Xisco: What distro are you running, so i can test that particular version.
Comment 7 Xisco Faulí 2016-03-05 14:20:41 UTC
uname -a prompts this: 4.2.0-30-generic #36-Ubuntu SMP Fri Feb 26 00:58:07 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
Comment 8 Yousuf Philips (jay) (retired) 2016-03-05 14:31:13 UTC
(In reply to Xisco Faulí from comment #7)
> uname -a prompts this: 4.2.0-30-generic #36-Ubuntu SMP Fri Feb 26 00:58:07
> UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

So if you are running linux 4.2, i'm assuming you are running the 15.10 release, so which Ubuntu flavour are you using (e.g. Kubuntu, Xubuntu)? Does the bug still arise for you now?

@Joel: Can you test your ubuntu version to see if this happens for you?
Comment 9 Joel Madero 2016-03-05 17:56:39 UTC
Bodhi Moksha
LibreOffice
Version: 5.2.0.0.alpha0+
Build ID: aaca25d67eb5ea252730cdcf555ecc04ce04a5e6
CPU Threads: 2; OS Version: Linux 3.16; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-24_23:58:47
Locale: en-US (en_US.UTF-8)


Cannot confirm.
Comment 10 Xisco Faulí 2016-03-08 11:26:52 UTC
So, If I download the latest daily build and I test it I can't reproduce it. However, if test it with Bibisect Linux x86_64 dbgutil I do reproduce it.
Comment 11 Yousuf Philips (jay) (retired) 2016-03-08 21:32:05 UTC
As the issue is with the bibisect build, i would say this is WFM. I've noticed stuff in the debug build that doesnt happen in regular build, e.g. bug 93953. If you disagree, please reset it to UNCONFIRMED.