Bug 97340 - Calc crashes on filtering with select checkbox with space bar
Summary: Calc crashes on filtering with select checkbox with space bar
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Dennis Francis
URL:
Whiteboard: target:5.3.0 target:5.2.0.1 target:5....
Keywords: haveBacktrace
: 100456 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-01-24 03:10 UTC by Jeong-Hwi RA
Modified: 2018-06-26 19:03 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
in filter, Just right before pressing space bar then it crashes (747.08 KB, image/png)
2016-01-24 03:10 UTC, Jeong-Hwi RA
Details
sample document (1.51 MB, application/vnd.oasis.opendocument.spreadsheet)
2016-01-24 08:32 UTC, Jeong-Hwi RA
Details
bt with debug symbols (10.03 KB, text/plain)
2016-01-24 12:06 UTC, Julien Nabet
Details
valgrind log (12.82 KB, text/plain)
2016-05-25 15:59 UTC, Caolán McNamara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeong-Hwi RA 2016-01-24 03:10:24 UTC
Created attachment 122181 [details]
in filter, Just right before pressing space bar then it crashes
Comment 1 raal 2016-01-24 07:27:04 UTC Comment hidden (obsolete)
Comment 2 raal 2016-01-24 07:28:08 UTC
Also please specify your version of LO.
Comment 3 Jeong-Hwi RA 2016-01-24 08:32:45 UTC
Created attachment 122186 [details]
sample document
Comment 4 Jeong-Hwi RA 2016-01-24 08:45:49 UTC
Added the document that showed the bug
Comment 5 Jeong-Hwi RA 2016-01-24 08:48:17 UTC
Version is 5.0.4.2
Comment 6 Julien Nabet 2016-01-24 12:06:51 UTC
Created attachment 122187 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I had a crash when doing these steps:
- open file
- click no when proposing to update links
- Click on F filter blue button to open filter dialog
- In "Search items..." area, type space then backspace
=> crash
I attached the bt with symbols.
Comment 7 Caolán McNamara 2016-05-25 15:59:59 UTC
Created attachment 125285 [details]
valgrind log
Comment 8 Dennis Francis 2016-06-06 11:28:30 UTC
Submitted a patch for review at https://gerrit.libreoffice.org/#/c/25850/
Comment 9 Commit Notification 2016-06-07 08:42:27 UTC
Dennis Francis committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f30aa6e51f7fe2fd3da47629de5a0dc13706e866

tdf#97340 : Handle autofilter search for dates correctly

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2016-06-07 08:44:55 UTC
Dennis Francis committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=848737eb576555f7c01d2159a9cf64d020dc2598&h=libreoffice-5-2

tdf#97340 : Handle autofilter search for dates correctly

It will be available in 5.2.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2016-06-10 13:30:29 UTC
Dennis Francis committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=760ca821442e3d8c0d36122bb8bc4a9c8078e97c&h=libreoffice-5-1

tdf#97340 : Handle autofilter search for dates correctly

It will be available in 5.1.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Caolán McNamara 2016-06-20 08:17:32 UTC
*** Bug 100456 has been marked as a duplicate of this bug. ***
Comment 13 Commit Notification 2018-06-26 19:03:01 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8e908ed926354703a00e19669e3f2631ebb05497

uitest for bug tdf#97340

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.