Bug 97399 - LO51RC1 Updating extensions on OSX is not possible - it freezes LO
Summary: LO51RC1 Updating extensions on OSX is not possible - it freezes LO
Status: RESOLVED DUPLICATE of bug 99784
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: high major
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-27 19:50 UTC by Martin Srebotnjak
Modified: 2017-10-27 11:08 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2016-01-27 19:50:37 UTC
Extension updating mechanism on OSX is in serious problems - if there is an update of an installed dictionary etc. or when clicking to check for updates in the Extension Manager on OSX - LO starts spinning the wheel and no operation is possible anymore.
It should be a stopper for 5.1.
Comment 1 Vincent Boudry 2016-02-12 08:50:08 UTC
For me with v5.1, it doesn't freeze LO, 
but the extension window is unresponsive as soon as the update button is pressed and this window (and LO altogether) cannot be closed anymore.

OSX 10.11.3

LO Version: 5.1.0.3
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: -; UI Render: default; 
Locale : fr-FR (fr.UTF-8)
Comment 2 Lunji 2016-02-24 00:03:58 UTC
Extension Manager freezes in LO 5.1.0.3 release version. Adding/managing extensions now becomes impossible. The LO was freshly downloaded and installed on a mac that never run LO earlier today. All settings are default. Language En-US. Mac OS X 10.9.5 with the latest security patches. No anti-virus or whatsoever
Comment 3 Alex Thurgood 2016-03-03 08:59:44 UTC

*** This bug has been marked as a duplicate of bug 95573 ***
Comment 4 Al Maloney 2016-10-16 20:25:11 UTC
Using LO 5.2.2 on Mac OS 10.11.6

When I "Check for updates" in Extension Manager, LO freezes and I have to Force Quit.

How is this bug (97399) RESOLVED?

It looks to me as if Bugs 95573 and 99784 refer to attempting to install extensions, not updating the installed extensions.
Comment 5 Xisco Faulí 2017-10-27 11:08:28 UTC

*** This bug has been marked as a duplicate of bug 99784 ***