Bug 97463 - PDF import: Draw does not import the background
Summary: PDF import: Draw does not import the background
Status: RESOLVED DUPLICATE of bug 96993
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.1.0.2 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-01-31 16:43 UTC by Jean-Baptiste Faure
Modified: 2016-02-02 05:41 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2016-01-31 16:43:16 UTC
Steps to reproduce:
- open the document here: https://bugs.documentfoundation.org/attachment.cgi?id=121079
- export this document in pdf format
- open the pdf with LO 5.1

What we get: the white text is not visible because the gray background is not there.

Best regards. JBF
Comment 1 Jean-Baptiste Faure 2016-01-31 16:50:09 UTC
Tested with my own build: Version: 5.1.1.0.0+
Build ID: 326418924702ef3a991db13c8d3e0f844985dada
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
Ubuntu_15.10_x86-64
Locale : fr-FR (fr_FR.UTF-8)

Same problem with Version: 5.2.0.0.alpha0+
Build ID: 161b39529260173749c10aa6728002ddd93bfcbe
CPU Threads: 4; OS Version: Linux 4.2; UI Render: GL; 
Ubuntu_15.10_x86-64
Locale: fr-FR (fr_FR.UTF-8)

Best regards. JBF
Comment 2 MM 2016-01-31 18:59:14 UTC
Unconfirmed with v5.0.5.1 under ubuntu 14.04 x64.
Confirmed with v5.1.0.3 under ubuntu 14.04 x64.
Comment 3 Jean-Baptiste Faure 2016-02-02 05:41:30 UTC
The fix for bug 96993 fixes this bug too in master branch:
- with the patch: LO Draw has the background of the pdf and the imported pdf is readable
- reverting locally the commit: no background.

So closing as duplicate of bug 96993.
I asked for a backport to 5.1 branch on bug 96993.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 96993 ***