Bug 97487 - Comments badly anchored when commenting the last word in a text
Summary: Comments badly anchored when commenting the last word in a text
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Comments
  Show dependency treegraph
 
Reported: 2016-02-01 16:43 UTC by noe.brucy
Modified: 2021-03-30 14:42 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Comment on last line (57.03 KB, image/png)
2016-02-01 16:43 UTC, noe.brucy
Details
After hitting Enter (55.13 KB, image/png)
2016-02-01 16:47 UTC, noe.brucy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description noe.brucy 2016-02-01 16:43:17 UTC
Created attachment 122317 [details]
Comment on last line

There is an annoying issue when commenting the last word in a text.
By clicking on "Enter" to start a new line, the comment will follow and point to the newly created line.

See attached screenshoots to understand.

A nice feature, solving partially this problem, would be to make it possible to move comments.
Comment 1 noe.brucy 2016-02-01 16:47:09 UTC
Created attachment 122318 [details]
After hitting Enter
Comment 2 noe.brucy 2016-02-01 16:48:47 UTC
There is no way to add text at the end of the document without moving the comment. The only way to do that is to delete the comment, press Enter and write the comment again.
Comment 3 raal 2016-02-02 08:33:39 UTC
Bug 64731 - Feature Request - Make text selection for comments moveable / editable 

Reproducible with Version: 5.2.0.0.alpha0+
Build ID: f4e703aa39e9c294441b6dd86189d8aff32db8bf
CPU Threads: 4; OS Version: Windows 6.1; UI Render: GL;
Comment 4 lsatenstein@yahoo.com 2017-02-06 14:05:03 UTC
Comment on attachment 122317 [details]
Comment on last line

I am experiencing this or similar problem
1) Creating a document by copying paragraphs from a text document
2) On the last line of document, I selected text and added a comment.
3) Comment was selected, Writer positioned the comment at the bottom (see above)
4) I needed to descend below the comment to add more text.    
5) Comment would descend with every new line that was entered.

Remedy
Save comment text contents, delete commment, add lines of new text at bottom and insert replacement comment with saved comment text
Comment 5 QA Administrators 2018-03-05 03:38:40 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2020-03-05 03:14:31 UTC Comment hidden (obsolete, spam)
Comment 7 Justin L 2020-12-24 07:37:16 UTC
Please retest with LO 7.2 eventually. I expect it is fixed courtesy of bug 120290.
Comment 8 Justin L 2021-03-30 14:42:55 UTC
works for me in 7.2+