Download it now!
Bug 97542 - INSERT: SVG text fill color not used
Summary: INSERT: SVG text fill color not used
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0
Keywords: filter:svg
Depends on:
Blocks: SVG-Import 97752
  Show dependency treegraph
 
Reported: 2016-02-03 21:28 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-10-25 19:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice (92.64 KB, image/png)
2016-02-03 21:28 UTC, Yousuf Philips (jay) (retired)
Details
Opera (224.87 KB, image/png)
2016-02-03 21:28 UTC, Yousuf Philips (jay) (retired)
Details
yellow rectangle with radial gradient text (547 bytes, image/svg+xml)
2016-02-08 15:11 UTC, JoNi
Details
gradial filled rectangle with yellow text (547 bytes, image/svg+xml)
2016-02-08 15:11 UTC, JoNi
Details
combined example with shapes (887 bytes, image/svg+xml)
2016-02-08 21:18 UTC, JoNi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-02-03 21:28:22 UTC
Created attachment 122365 [details]
LibreOffice

Steps:
1) Open Writer
2) Insert https://dev.w3.org/SVG/tools/svgweb/samples/svg-files/displayWebStats.svg
3) Compare the output with what you can find in your browser or inkscape and see that the help and mode buttons on the top left and right are supposed to be in yellow.

The SVG code states that the text is yellow with 'fill="yellow"', but instead there is a gradient on it.

<text x="0" y="5" font-size="12" stroke="none" fill="yellow" text-anchor="middle" font-weight="bold">HELP</text>

<text x="0" y="5" font-size="12" stroke="none" fill="yellow" text-anchor="middle" font-weight="bold">MODE</text>

Version: 5.2.0.0.alpha0+
Build ID: 513d5c5781ec14f8512432f31290a3d54c8d57df
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-01_10:25:20
Locale: en-US (en_US.UTF-8)
Comment 1 Yousuf Philips (jay) (retired) 2016-02-03 21:28:41 UTC
Created attachment 122366 [details]
Opera
Comment 2 raal 2016-02-04 09:11:59 UTC
I can confirm with Version: 5.2.0.0.alpha0+
Comment 3 Xisco Faulí 2016-02-04 11:19:04 UTC
The problem is that the button text is taking the fill attribute from its parents instead of using its own. I'll take a look
Comment 4 Xisco Faulí 2016-02-04 23:48:26 UTC
Commit submitted to gerrit: https://gerrit.libreoffice.org/#/c/22131/
Comment 5 JoNi 2016-02-08 15:11:09 UTC
Created attachment 122442 [details]
yellow rectangle with radial gradient text
Comment 6 JoNi 2016-02-08 15:11:59 UTC
Created attachment 122443 [details]
gradial filled rectangle with yellow text
Comment 7 JoNi 2016-02-08 21:18:11 UTC
Created attachment 122464 [details]
combined example with shapes
Comment 8 Commit Notification 2016-02-11 17:19:10 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b6a62f07557fe4ae0931e0f3e0f306d2f69b116b

tdf#97542: SVGIO: First check the current fill attribute

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Yousuf Philips (jay) (retired) 2016-02-18 14:09:47 UTC
Version: 5.2.0.0.alpha0+
Build ID: 72720ac9b934af6f84111ec694fa46555d10a7bd
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-17_19:06:34
Locale: en-US (en_US.UTF-8)