Download it now!
Bug 97566 - INSERT: SVG redraw at different zoom/resize levels crops content
Summary: INSERT: SVG redraw at different zoom/resize levels crops content
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.3.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:svg
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2016-02-04 12:18 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-06-21 11:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-02-04 12:18:12 UTC
Steps:
1) Open Writer
2) Insert https://dev.w3.org/SVG/tools/svgweb/samples/svg-files/DroidSans.svg
3) Notice that all of the '_' character is being displayed at 100% zoom and increasing or decreasing the zoom level or resizing the svg size will cause all of '_' and '^' to appear or disappear.

Version: 5.2.0.0.alpha0+
Build ID: 513d5c5781ec14f8512432f31290a3d54c8d57df
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-01_10:25:20
Locale: en-US (en_US.UTF-8)
Comment 1 Buovjaga 2016-02-11 12:00:24 UTC
Repro.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: a6f876d45bd4e41a7143594a6cb11b6893a0f620
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-11_00:07:38
Locale: fi-FI (fi_FI)
Comment 2 QA Administrators 2017-03-06 15:48:46 UTC Comment hidden (obsolete)
Comment 3 Roman Kuznetsov 2018-06-19 19:49:46 UTC
don't repro in 6.1 beta 2

but bottom text "SVG Open 2009" shows not correctly -> this will be a new bug, imho

Status -> WFM
Comment 4 Buovjaga 2018-06-21 11:11:44 UTC
(In reply to kompilainenn from comment #3)
> but bottom text "SVG Open 2009" shows not correctly -> this will be a new
> bug, imho

Not a bug: it shows the same in Inkscape and Chrome. In Firefox, IE11 and Edge the font is the same size as the rest of the text (wrong).
 
Edit the SVG file to see that the font size should be 50:
<text style="fill:rgb(200, 200, 200); stroke: rgb(247, 170, 21);font-size:50" stroke="orange" x="20" y="300">SVG Open 2009</text>