Download it now!
Bug 97582 - INSERT: Rims of SVG car missing
Summary: INSERT: Rims of SVG car missing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: All All
: medium normal
Assignee: Xisco Faulí
URL:
Whiteboard:
Keywords: bibisectRequest, filter:svg, regression
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2016-02-04 19:14 UTC by Yousuf Philips (jay) (retired)
Modified: 2019-09-20 13:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
4.3 vs 5.2 (136.61 KB, image/png)
2016-02-04 19:14 UTC, Yousuf Philips (jay) (retired)
Details
Simplier sample (424 bytes, image/svg+xml)
2016-02-16 10:46 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-02-04 19:14:07 UTC
Created attachment 122394 [details]
4.3 vs 5.2

Steps:
1) Open Writer
2) Insert https://dev.w3.org/SVG/tools/svgweb/samples/svg-files/gallardo.svg
3) Notice that the rims on the 2 tires are missing

Regression as the rims are there in 4.3.7.

Version: 5.2.0.0.alpha0+
Build ID: 513d5c5781ec14f8512432f31290a3d54c8d57df
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-01_10:25:20
Locale: en-US (en_US.UTF-8)
Comment 1 raal 2016-02-05 08:41:50 UTC
I can confirm with Version: 5.2.0.0.alpha0+
Comment 2 Xisco Faulí 2016-02-05 13:46:12 UTC
It looks like the problem occurs when the g element contains the attribute style, in this case style="opacity:1;display:inline", which looks to affect to its children. I'll take a look...
Comment 3 Xisco Faulí 2016-02-16 10:46:52 UTC
Created attachment 122675 [details]
Simplier sample

Problem appears when an element contains the attributes clip-path and style as the the style is applied to the element instead of to the clip-path element