Bug 97616 - Calc conditional formatting: fast scrolling down and up shows borders that shouldn't be there
Summary: Calc conditional formatting: fast scrolling down and up shows borders that sh...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2016-02-07 11:24 UTC by Aldo
Modified: 2019-01-14 12:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
ods file (17.36 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-02-07 11:24 UTC, Aldo
Details
Image of the proper situation (294.98 KB, application/pdf)
2016-02-07 19:14 UTC, Aldo
Details
File ods (15.80 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-02-08 09:44 UTC, Aldo
Details
image of the screen (217.94 KB, image/jpeg)
2016-02-08 09:47 UTC, Aldo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aldo 2016-02-07 11:24:27 UTC
Created attachment 122422 [details]
ods file

If A5 A420 <> 1, applies style 'In Evidenza', with lined cells.

Scrolling down and up, they appear some edges that should not appear.

Sorry for my english.

Can I write Italian?
Comment 1 Aldo 2016-02-07 19:14:13 UTC Comment hidden (obsolete)
Comment 2 Aldo 2016-02-07 19:27:30 UTC Comment hidden (obsolete)
Comment 3 m.a.riosv 2016-02-07 20:58:53 UTC
HI @Aldo, thanks for reporting.

Sorry but the only language here is the English.

The conditional format in your file works fine, for the range specified.

Cells A4 and A421 has there own direct format and has nothing to do with the Conditional Format. Doing a [Ctrl+M] or Menu/Format/Clear direct formatting on this cells. Be care if you make [Ctrl+M] on the whole cells then you clear the CF.

Resolved as notabug, please if you are not agree reopen it.

You can find help in Italian in Ask and in Mailing list:

https://ask.libreoffice.org/it/questions/
Comment 4 Aldo 2016-02-08 09:44:09 UTC
Created attachment 122432 [details]
File ods
Comment 5 Aldo 2016-02-08 09:47:48 UTC
Created attachment 122433 [details]
image of the screen

This is what I see on the screen
Comment 6 Aldo 2016-02-08 09:59:25 UTC
Thanks, but the problem continues


If I delete the conditional formatting, the problem disappears.

On the cells there is no direct formatting with the edge.
Comment 7 Aldo 2016-02-08 10:10:38 UTC
If only the border erase by formatting style used in the conditional formatting, the problem disappears.
Comment 8 Markus Mohrhard 2016-03-26 18:09:41 UTC
Looks like a simple fix.
Comment 9 Xisco Faulí 2017-09-21 08:49:04 UTC Comment hidden (obsolete)
Comment 10 QA Administrators 2018-09-22 02:44:13 UTC Comment hidden (obsolete)
Comment 11 Xavier Van Wijmeersch 2018-09-22 09:02:00 UTC
I did find a lot of exel formatting in the right status bar; styles and formatting cell's
Changing 'cell value is not equal to 1' to 'formula is A1<>1' give no appearing lines

So for me not a bug

Best regards

Version: 6.2.0.0.alpha0+
Build ID: 11a229c0094979b4980d8e3be8a8a7db60d01be7
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: threaded
Comment 12 Timur 2019-01-14 12:55:29 UTC
No repro 4.3. Repro with LO 4.4 and 6.3+. Looks like regression.