Bug 97633 - VCL: UNO API for getBufferSwapCounter()
Summary: VCL: UNO API for getBufferSwapCounter()
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:5.1.1
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-08 09:43 UTC by Miklos Vajna
Modified: 2016-10-25 19:17 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miklos Vajna 2016-02-08 09:43:16 UTC
VCL's OpenGLWrapper::getBufferSwapCounter() is useful to monitor how many frames are rendered on the screen / second. It would be useful to expose this in our UNO API as well.
Comment 1 Miklos Vajna 2016-02-08 09:44:02 UTC
Oh, it turns out 2c55288357c9d5410afae58c1fbb97cdfabf0360 even adds the UNO wrapper of master, so it would be only a matter of backporting the API to libreoffice-5-1.
Comment 2 Commit Notification 2016-02-08 14:16:24 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=59ebd032b834f31f2b3069395f7e7962a0adfea2&h=libreoffice-5-1

tdf#97633 Add API to get the number of OpenGL buffer swaps, including ...

It will be available in 5.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.