Bug Hunting Session
Bug 97635 - Beanshell Editor: Shift-Tab doesn't work
Summary: Beanshell Editor: Shift-Tab doesn't work
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Andreas Heinisch
URL:
Whiteboard: target:6.3.0
Keywords:
Depends on:
Blocks: Beanshell-Editor
  Show dependency treegraph
 
Reported: 2016-02-08 11:42 UTC by Samuel Mehrbrodt (CIB)
Modified: 2019-05-21 11:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mehrbrodt (CIB) 2016-02-08 11:42:52 UTC
In the Beanshell Editor, indenting code with Tab doesn't work.
Comment 1 Samuel Mehrbrodt (CIB) 2016-02-08 11:44:11 UTC
Oops .. Tab does work, but Shift-Tab doesn't.
Comment 2 Buovjaga 2016-02-11 10:13:19 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: a6f876d45bd4e41a7143594a6cb11b6893a0f620
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-11_00:07:38
Locale: fi-FI (fi_FI)
Comment 3 Andreas Heinisch 2019-05-08 13:46:09 UTC
A short question: if I Shift-Tab in a line without any tab, what should be the intended behaviour? 

For instance, in Eclipse, Shift-Tab removes only tabs at the beginning of a line until no more tabs are present.
Comment 4 Samuel Mehrbrodt (CIB) 2019-05-08 13:48:50 UTC
(In reply to Andreas Heinisch from comment #3)
> A short question: if I Shift-Tab in a line without any tab, what should be
> the intended behaviour? 
> 
> For instance, in Eclipse, Shift-Tab removes only tabs at the beginning of a
> line until no more tabs are present.

Yeah just do something sensible then, maybe just copy Eclipse's behavior.
Comment 5 Commit Notification 2019-05-16 09:33:31 UTC
Andreas Heinisch committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/e875a317c4adf00bbad00fb8176c26cd1a66973e%5E%21

tdf#97635 Added unindentation using shift-tab (mimicked eclipse behavior)

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Andreas Heinisch 2019-05-19 19:12:55 UTC
I did some tests with the shift+tab patch and I don't know if we should move the functionality to the keyPressed function? This would allow the user to press the shift+tab continuously and not only once per input.
Comment 7 Samuel Mehrbrodt (CIB) 2019-05-20 06:20:51 UTC
(In reply to Andreas Heinisch from comment #6)
> I did some tests with the shift+tab patch and I don't know if we should move
> the functionality to the keyPressed function? This would allow the user to
> press the shift+tab continuously and not only once per input.

Ah good point, feel free to create a follow-up patch for that.
Comment 8 Commit Notification 2019-05-20 13:45:42 UTC
Andreas Heinisch committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/9ee0a1f16682139c5be28a05d33e980123da4c6f%5E%21

tdf#97635 Added unindentation using shift-tab (mimicked eclipse's behavior)

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.