Bug 97659 - SVG doesnt support rgba() in fill attribute
Summary: SVG doesnt support rgba() in fill attribute
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.0.6.2 release
Hardware: All All
: medium normal
Assignee: Xisco Faulí
QA Contact:
URL:
Whiteboard: target:5.2.0
Keywords: filter:svgInsert
Depends on:
Blocks: SVG-Insert
  Show dependency treegraph
 
Reported: 2016-02-08 20:16 UTC by Yousuf Philips (jay)
Modified: 2016-10-25 19:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2016-02-08 20:16:32 UTC
Steps:
1) Open Writer
2) Insert https://dev.w3.org/SVG/tools/svgweb/samples/svg-files/mouseEvents.svg
3) Notice that three squares are in grey when they should be in green.

The problem is that the SVG code does support the fill attribute having an rgba() value like:

<rect ... fill="rgba(255,0,0,.5)" .../>

The old SVG implementation code found in 3.6.7 didnt have this problem.

Version: 5.2.0.0.alpha0+
Build ID: 6d68e88a0fc5a54bbb826379163bd0b9c6eae0fb
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-08_08:05:38
Locale: en-US (en_US.UTF-8)
Comment 1 Xisco Faulí 2016-02-09 10:51:37 UTC
Correct, SVGIO supports RGB but not RGBA. I'll take a look at it
Comment 2 Commit Notification 2016-02-13 13:40:58 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3c8b880c5edc1dcbf0f481c558c6093513df6b45

SVGIO: tdf#97659: Add support for RGBA

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Yousuf Philips (jay) 2016-02-18 14:02:43 UTC
Version: 5.2.0.0.alpha0+
Build ID: 72720ac9b934af6f84111ec694fa46555d10a7bd
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-17_19:06:34
Locale: en-US (en_US.UTF-8)