Bug 97664 - Exporting to PDF do not show some embedded Draw 8 format images
Summary: Exporting to PDF do not show some embedded Draw 8 format images
Status: RESOLVED DUPLICATE of bug 99680
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2016-02-08 21:11 UTC by SimonB
Modified: 2016-09-24 14:40 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
LibreOffice 5.1 original ODT file containing Draw 8 embedded images + output PDFs for 4.4.7 and 5.1.0 (155.61 KB, application/zip)
2016-02-08 21:11 UTC, SimonB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description SimonB 2016-02-08 21:11:36 UTC
Created attachment 122463 [details]
LibreOffice 5.1 original ODT file containing Draw 8 embedded images + output PDFs for 4.4.7 and 5.1.0

New with 5.x:

Exporting to PDF do not show some embedded Draw 8 format images

Images will export perfectly with 4.2, 4.3 and 4.4.x  (using 4.4.7 now)

This bug is present with 5.0.4 & 5.1.0 rc
Not related to image compression options nor OpenGL rendering.

Print to a file (and save to PDF) will work but is not an acceptable work around.
Comment 1 Buovjaga 2016-02-11 13:02:31 UTC
Repro.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: a6f876d45bd4e41a7143594a6cb11b6893a0f620
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-11_00:07:38
Locale: fi-FI (fi_FI)
Comment 2 raal 2016-02-19 07:46:53 UTC
This seems to have begun at the below commit.
Adding Cc: to Thorsten Behrens; Could you possibly take a look at this one? Thanks
 9e18c6eee5d11950b9622b2905e272f129d2f444 is the first bad commit
commit 9e18c6eee5d11950b9622b2905e272f129d2f444
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Aug 13 09:45:06 2015 -0700

    source sha:86b47f5138c0c5b882359a48052a796bc91a5afb

    source sha:86b47f5138c0c5b882359a48052a796bc91a5afb

:040000 040000 5d06c87f827c7ef96ec92843596cb96f7a98c353 cdbe206fdb3d25a503fcfb9b7b45bc433bf1fc14 M      instdir

author	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2015-08-13 15:17:22 (GMT)
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2015-08-13 16:26:01 (GMT)
commit 86b47f5138c0c5b882359a48052a796bc91a5afb (patch)
tree eba136edac7f69b48643cff81aebb4d9ce389698
parent 07ebec47da4a096aaab53bf6a90bb219ce29bfbf (diff)
tdf#44388: handle the NULL clip correctly for pdf output
Comment 3 SimonB 2016-03-02 22:17:19 UTC
Hi all,
Any update on this bug?

Thank you
Comment 4 Colin 2016-04-14 05:29:18 UTC
As a workaround only; I believe that if you change the anchor of the images to As Character then the export works ok. (Right click on image Anchor -> As Character)
Comment 5 SimonB 2016-04-14 12:59:29 UTC
(In reply to Colin from comment #4)
> As a workaround only; I believe that if you change the anchor of the images
> to As Character then the export works ok. (Right click on image Anchor -> As
> Character)

Hi Colin,
 I tried your work around. It will fix it for some of the drawings but most will still not export to PDF. Thanks for trying to help though

Any chance to see that problem fixed at the source ?  
We will be forced to convert all our internal documentation (many documents of several hundreds of pages with hundreds of drawings in Draw8 format) we have to Microsoft Word if this is not fixed soon. We would prefer to continue to use LibreOffice but this problem is a show stopper for us.

Any way I can help ?

Regards
Simon B.
Comment 6 raal 2016-04-14 13:48:12 UTC
(In reply to SimonB from comment #5)

> Any chance to see that problem fixed at the source ?  
> We will be forced to convert all our internal documentation (many documents
> of several hundreds of pages with hundreds of drawings in Draw8 format) we
> have to Microsoft Word if this is not fixed soon. We would prefer to
> continue to use LibreOffice but this problem is a show stopper for us.
> 

Hello Simon, you can contact some of the companies listed here: https://www.documentfoundation.org/gethelp/developers/
Comment 7 Xisco Faulí 2016-09-24 14:40:11 UTC

*** This bug has been marked as a duplicate of bug 99680 ***