Download it now!
Bug 97676 - FILEOPEN: Wrong page break in Microsoft docx file (caused by different handling of paragraph setting keep with next ?)
Summary: FILEOPEN: Wrong page break in Microsoft docx file (caused by different handli...
Status: RESOLVED DUPLICATE of bug 98700
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: filter:doc, filter:docx
Depends on:
Blocks: DOCX
  Show dependency treegraph
 
Reported: 2016-02-09 08:13 UTC by Oliver Specht (CIB)
Modified: 2017-03-21 22:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Paragraphs are wrongly moved to the second page (14.77 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-02-09 08:13 UTC, Oliver Specht (CIB)
Details
result in L) 5052 (100.41 KB, image/png)
2016-02-09 08:57 UTC, Cor Nouws
Details
Screenshot from LibO 5.2 (151.07 KB, image/jpeg)
2016-02-11 15:46 UTC, Buovjaga
Details
original file, all heading 3 > standard (11.78 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-02-12 16:08 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Specht (CIB) 2016-02-09 08:13:40 UTC
Created attachment 122472 [details]
Paragraphs are wrongly moved to the second page

Writer starts the second page with the paragraph 
"Ut tincidunt volutpat ..." and leaves enough free space on the first page to put this and the next paragraph on it.
Probably because all paragraphs have 'keep with next paragraph' active it decides wrongly and prefers to keep the paragraph at the end together instead of those in the beginning.
Comment 1 Cor Nouws 2016-02-09 08:57:22 UTC
Created attachment 122475 [details]
result in L) 5052

Hi Oliver,

I do not see the problem in 5052.
Interesting the paragraph style is Header 3
Comment 2 Cor Nouws 2016-02-09 08:59:25 UTC
And I don't see it on master either
 
Version: 5.2.0.0.alpha0+
Build ID: 6d68e88a0fc5a54bbb826379163bd0b9c6eae0fb
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86@71-TDF, Branch:master, Time: 2016-02-08_08:04:35
Locale: nl-NL (nl_NL.UTF-8)
Comment 3 Cor Nouws 2016-02-09 09:00:42 UTC
Font related? Maybe my Carlia and Caladeo match fine with Calibri?
Comment 4 Buovjaga 2016-02-11 15:46:03 UTC
Created attachment 122535 [details]
Screenshot from LibO 5.2

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: a6f876d45bd4e41a7143594a6cb11b6893a0f620
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-11_00:07:38
Locale: fi-FI (fi_FI)
Comment 5 Buovjaga 2016-02-11 15:46:51 UTC
Confirmed.
I installed Calibri Light from https://support.microsoft.com/fi-fi/kb/2761217
Comment 6 Cor Nouws 2016-02-11 16:46:57 UTC
Calibri can be replaced by Carlito, and Cambria by Caladea.
Why minor, By the way?
Comment 7 Buovjaga 2016-02-11 16:55:59 UTC
(In reply to Cor Nouws from comment #6)
> Calibri can be replaced by Carlito, and Cambria by Caladea.
> Why minor, By the way?

Because it is a special case and doesn't prevent us from creating high quality work?
Comment 8 Cor Nouws 2016-02-12 08:57:11 UTC
(In reply to Beluga from comment #7)
> (In reply to Cor Nouws from comment #6)
> > Calibri can be replaced by Carlito, and Cambria by Caladea.
> > Why minor, By the way?
> 
> Because it is a special case and doesn't prevent us from creating high
> quality work?

IMO interoperability issues should never be considered minor. Do we need to discuss the scheme for those again?
Comment 9 Buovjaga 2016-02-12 09:08:23 UTC
(In reply to Cor Nouws from comment #8)
> (In reply to Beluga from comment #7)
> > (In reply to Cor Nouws from comment #6)
> > > Calibri can be replaced by Carlito, and Cambria by Caladea.
> > > Why minor, By the way?
> > 
> > Because it is a special case and doesn't prevent us from creating high
> > quality work?
> 
> IMO interoperability issues should never be considered minor. Do we need to
> discuss the scheme for those again?

Yeah, you need to update the flowchart: https://wiki.documentfoundation.org/QA/BugTriage#Step_7._Prioritize_Bug
Comment 10 Buovjaga 2016-02-12 09:09:42 UTC
Btw. why change the summary to: Writer: Wrong page break when Microsoft proprietary lock-in font Calibri (or substitute) is not available

I see the problem when Calibri Light IS installed.
Comment 11 Cor Nouws 2016-02-12 09:30:06 UTC
(In reply to Beluga from comment #10)
> Btw. why change the summary to: Writer: Wrong page break when Microsoft
> proprietary lock-in font Calibri (or substitute) is not available
> 
> I see the problem when Calibri Light IS installed.

Sorry, I misunderstood you then!
Then what is the problem... I only have Caladeo en Carlita, but do not have the problem.. Maybe it is not Calibri.

In your screenshot, is that the page break to second on third page?

For me, from page 1 to 2 it is correct, but I see a similar problem with page 2 to 3 here..
Comment 12 Buovjaga 2016-02-12 09:38:28 UTC
(In reply to Cor Nouws from comment #11)
> (In reply to Beluga from comment #10)
> > Btw. why change the summary to: Writer: Wrong page break when Microsoft
> > proprietary lock-in font Calibri (or substitute) is not available
> > 
> > I see the problem when Calibri Light IS installed.
> 
> Sorry, I misunderstood you then!
> Then what is the problem... I only have Caladeo en Carlita, but do not have
> the problem.. Maybe it is not Calibri.
> 
> In your screenshot, is that the page break to second on third page?
> 
> For me, from page 1 to 2 it is correct, but I see a similar problem with
> page 2 to 3 here..

There is no actual physical page break - it is due to the "keep with next.." Oliver mentioned in the desc.
Comment 13 Cor Nouws 2016-02-12 11:34:23 UTC
(In reply to Beluga from comment #12)

> There is no actual physical page break - it is due to the "keep with next.."
> Oliver mentioned in the desc.

I know, I should have written page crossing.. The question still stands :)
Comment 14 Buovjaga 2016-02-12 12:06:52 UTC
(In reply to Cor Nouws from comment #13)
> (In reply to Beluga from comment #12)
> 
> > There is no actual physical page break - it is due to the "keep with next.."
> > Oliver mentioned in the desc.
> 
> I know, I should have written page crossing.. The question still stands :)

My screenshot is from 1-2, like Oliver reported.
Comment 15 Cor Nouws 2016-02-12 13:31:02 UTC
(In reply to Beluga from comment #14)

> My screenshot is from 1-2, like Oliver reported.

And I have a similar problem from 2-3 :)
Comment 16 Oliver Specht (CIB) 2016-02-12 14:19:06 UTC
I think that the problem of wrong page breaks can happen everywhere. Just remove some of the keep with next attributes and delete/undo a paragraph break.
Comment 17 Cor Nouws 2016-02-12 16:05:33 UTC
(In reply to Oliver Specht (CIB) from comment #16)
> I think that the problem of wrong page breaks can happen everywhere. 

Indeed. In my first tests, I did look at all page crossings and none had a special gap..
Comment 18 Cor Nouws 2016-02-12 16:08:53 UTC
Created attachment 122582 [details]
original file, all heading 3 > standard

changing Heading 3 to Standard _seems_ to make the problem disappear..
Comment 19 Kevin Suo 2017-03-21 00:22:12 UTC
Is this a duplicate of bug 98700?
Comment 20 Buovjaga 2017-03-21 10:38:05 UTC
(In reply to Kevin Suo from comment #19)
> Is this a duplicate of bug 98700?

Yes, it seems to be a dupe: I tested with your attachment and if I change the BBB.. paragraph style to Default from Heading, the direct formatting Keep with next paragraph stays disabled.

Any ideas which to change as duplicate?
Comment 21 Kevin Suo 2017-03-21 22:48:16 UTC

*** This bug has been marked as a duplicate of bug 98700 ***