Bug Hunting Session
Bug 97687 - VIEWING: text cursor stop blinking after you double click a bookmark in "navigation" window and close this window.
Summary: VIEWING: text cursor stop blinking after you double click a bookmark in "navi...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: VclPtr
  Show dependency treegraph
 
Reported: 2016-02-09 12:51 UTC by Alex
Modified: 2019-08-10 07:28 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2016-02-09 12:51:20 UTC
1) Open a text document in Writer.
2) move the text cursor to a preferred position in the text, and here create a    bookmark.
3) Open the "Navigation" window, and under the voice "bookmark", double click on the bookmark created in 2).

Now, the text cursor is blinking at the right text position where you saved the bookmark.

Here arise the PROBLEM: when you close the "Navigation" window, the text cursor stop blinking and his position become invisible.

.....Note that, as workaround to this problem, I must to minimize the Writer main window and then restore it on the screen, after doing this, the text cursor returns to blink normally. 
Another workaround: scroll the document until the hidden text cursor go out of the window and then scroll back the document.
Comment 1 Cor Nouws 2016-02-09 17:10:05 UTC
Hi Alex,

Thanks for filing. This does not happen in 5.0.5.2 on Ubuntu 32 bits with OpenGL (... Options > LibreOffice > View) diabled.

Ciao - Cor
Comment 2 Alex 2016-02-09 17:35:04 UTC
(In reply to Cor Nouws from comment #1)
> Hi Alex,
> 
> Thanks for filing. This does not happen in 5.0.5.2 on Ubuntu 32 bits with
> OpenGL (... Options > LibreOffice > View) diabled.
> 
> Ciao - Cor



Hi Cor Nouws,

I've tried to change the settings related to OpenGL,hardware acceleration and anti-aliasing, but the problem is still present.
Comment 3 Cor Nouws 2016-02-09 18:44:03 UTC
(In reply to Alex from comment #2)
Hi Alex,

> I've tried to change the settings related to OpenGL,hardware acceleration
> and anti-aliasing, but the problem is still present.

Might well be Windows-specific
Comment 4 Buovjaga 2016-02-12 16:27:19 UTC
Repro.

Problem not present in 4.3

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: a6f876d45bd4e41a7143594a6cb11b6893a0f620
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-11_00:07:38
Locale: fi-FI (fi_FI)

4.3.0.1
Comment 5 raal 2016-02-24 10:30:20 UTC
This seems to have begun at the below commit.
Adding Cc: to Michael Meeks; Could you possibly take a look at this one? Thanks

ba5c12eeb1977bd3f7466df16a94b4c6f9523f6e is the first bad commit
commit ba5c12eeb1977bd3f7466df16a94b4c6f9523f6e
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Tue Jul 14 14:13:07 2015 -0700

    source sha:7aae8772aa18744cb1bbd8348272be99cc882c47

    source sha:7aae8772aa18744cb1bbd8348272be99cc882c47

:040000 040000 585263ef01040b84876a862f697845c7f2435edf 45e0fefb5f34497a31fce6cb9e1a52b558c143a4 M      instdir

author	Michael Meeks <michael.meeks@collabora.com>	2015-06-05 15:37:49 (GMT)
committer	Michael Meeks <michael.meeks@collabora.com>	2015-06-05 19:45:12 (GMT)
commit	7aae8772aa18744cb1bbd8348272be99cc882c47 (patch)
tree	c4824605af0def9fe11cb1c302f9b0e18993c06e
parent	b9f95769495e8d9885b64f1d68118336a4fc8d38 (diff)
Clear VclPtr instance reference on removed UserEvents.
Comment 6 Björn Michaelsen 2016-04-16 16:53:49 UTC
blocks vclptr as per comment 5
Comment 7 Julien Nabet 2016-10-23 11:51:31 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this problem.
But when navigator is opened, cursor doesn't blink. It blinks again if I double click on the bookmark and also after having close navigator window.
Comment 8 QA Administrators 2018-07-28 02:43:16 UTC Comment hidden (obsolete)
Comment 9 Buovjaga 2019-08-09 11:13:36 UTC
(In reply to Julien Nabet from comment #7)
> On pc Debian x86-64 with master sources updated today, I don't reproduce
> this problem.
> But when navigator is opened, cursor doesn't blink. It blinks again if I
> double click on the bookmark and also after having close navigator window.

Julien: can you try reproducing the "But when navigator is opened" problem? I can't reproduce even that one.

There are only 3 open bugs in the VclPtr meta report and it would be great, if the whole thing could be closed. It concerns a specific historical situation anyway, so there is no need to keep it open forever.

Version: 6.4.0.0.alpha0+ (x64)
Build ID: ed882d693f37779e3a09641e7cd43b7a925d2312
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-07-25_00:58:18
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded
(tried also without OpenGL)
Comment 10 Julien Nabet 2019-08-09 21:28:30 UTC
(In reply to Buovjaga from comment #9)
> (In reply to Julien Nabet from comment #7)
> > On pc Debian x86-64 with master sources updated today, I don't reproduce
> > this problem.
> > But when navigator is opened, cursor doesn't blink. It blinks again if I
> > double click on the bookmark and also after having close navigator window.
> 
> Julien: can you try reproducing the "But when navigator is opened" problem?
> I can't reproduce even that one.
>...
On pc Debian x86-64 with master sources updated today, I don't reproduce this.
Comment 11 Buovjaga 2019-08-10 07:28:51 UTC
Great, let's close