Download it now!
Bug 97690 - Stroke on pointed line should be flat in SVG
Summary: Stroke on pointed line should be flat in SVG
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.0.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:svg
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2016-02-09 14:31 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-06-20 12:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
how it looks in Opera (24.82 KB, image/png)
2016-02-09 14:31 UTC, Yousuf Philips (jay) (retired)
Details
pdftk.svg - LibreOfficeDev Draw 6.1 beta 2 (23.74 KB, image/png)
2018-06-20 12:16 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-02-09 14:31:34 UTC
Created attachment 122482 [details]
how it looks in Opera

Steps:
1) Open Writer
2) Insert https://dev.w3.org/SVG/tools/svgweb/samples/svg-files/pdftk.svg
3) Notice the orange stroke on the yellow flash has pointed ends

Relevant SVG code: <path d='M59,42l-26-5l20-5l-12-18l18,13l4-23l5,22l17-12l-11,17l22,6l-23,3l14,20l-18-13l-6,21z' fill='#FF0' stroke='#fb8'/>

The old SVG implementation code found in 3.6.7 didnt have this problem.

Version: 5.2.0.0.alpha0+
Build ID: 6d68e88a0fc5a54bbb826379163bd0b9c6eae0fb
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-08_08:05:38
Locale: en-US (en_US.UTF-8)
Comment 1 Yousuf Philips (jay) (retired) 2016-02-10 16:50:53 UTC
Same thing occurred here with <path d="M40,73h27l-20,7" ...>

https://dev.w3.org/SVG/tools/svgweb/samples/svg-files/why.svg
Comment 2 Buovjaga 2016-02-12 15:54:33 UTC
Confirmed, corrected summary.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: a6f876d45bd4e41a7143594a6cb11b6893a0f620
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-11_00:07:38
Locale: fi-FI (fi_FI)
Comment 3 Regina Henschel 2016-03-23 15:38:14 UTC
It seems to be a problem with miter limit, therefore likely connected to bug 48066.
Comment 4 QA Administrators 2017-05-22 13:20:28 UTC Comment hidden (obsolete)
Comment 5 Roman Kuznetsov 2018-06-20 12:16:58 UTC
Created attachment 142959 [details]
pdftk.svg - LibreOfficeDev Draw 6.1 beta 2

looks as screenshot from Yousuf

status -> WFM