Download it now!
Bug 97715 - TDR triggered: opengl rotation of huge images shrunk to tiny pixel size.
Summary: TDR triggered: opengl rotation of huge images shrunk to tiny pixel size.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.1.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0 target:5.1.2
Keywords:
: 97714 97796 (view as bug list)
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2016-02-10 16:16 UTC by Michael Meeks
Modified: 2016-10-25 19:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
file hangs with TDF on windows during load (2.39 MB, application/vnd.oasis.opendocument.graphics)
2016-02-10 16:23 UTC, Michael Meeks
Details
apitrace output - also causes a TDR in qapitrace =) (4.95 MB, application/octet-stream)
2016-02-10 16:32 UTC, Michael Meeks
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2016-02-10 16:16:52 UTC

    
Comment 1 Michael Meeks 2016-02-10 16:17:13 UTC
*** Bug 97714 has been marked as a duplicate of this bug. ***
Comment 2 Michael Meeks 2016-02-10 16:19:05 UTC
When using OpenGL it is possible to trigger the TDR timeout on windows with the right combination of scaling and rotating of a very large image under AMD hardware (at least). In this case a:

 JPEG 3340x1827 8 bit grey jpeg.

I attach a corner-case file that reproduces this.
Comment 3 Michael Meeks 2016-02-10 16:23:05 UTC
Created attachment 122501 [details]
file hangs with TDF on windows during load

Interestingly, works nicely under Linux for me.
Comment 4 Michael Meeks 2016-02-10 16:32:32 UTC
Created attachment 122502 [details]
apitrace output - also causes a TDR in qapitrace =)
Comment 5 Michael Meeks 2016-02-10 17:31:11 UTC
On my windows machine the API trace TDRs when we get to between call 103327 and 103328 ;-) when we get to this stage the back-buffer texture looks -really- odd in qapitrace - as if it is made up of staggered and partially mangled junk ;-) - not ideal !
Comment 6 Commit Notification 2016-02-11 17:10:15 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=54e3ea8a86a309990f5edf78948bfe18dd2de96b

tdf#97715 fix inv. scale calculation in DrawTransformedTexture

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2016-02-11 17:12:29 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6fb42845b82cc3b065dd788278c08cdacda1e5cc&h=libreoffice-5-1

tdf#97715 fix inv. scale calculation in DrawTransformedTexture

It will be available in 5.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Michael Meeks 2016-02-11 17:24:08 UTC
Thanks Tomaz - closing this guy then =) nice - it was the only TDR that I still knew of and it worried me ...
Comment 9 Michael Meeks 2016-02-15 11:54:45 UTC
*** Bug 97796 has been marked as a duplicate of this bug. ***