Bug Hunting Session
Bug 97760 - Icons only gray boxes
Summary: Icons only gray boxes
Status: RESOLVED DUPLICATE of bug 97816
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-11 16:44 UTC by exxonse
Modified: 2016-02-16 12:17 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
The icons for cut, copy, paste, undo and restore are after updating to 5.1.0.3 only gray boxes (171.37 KB, image/jpeg)
2016-02-11 16:44 UTC, exxonse
Details
strange icons (79.40 KB, image/png)
2016-02-11 18:17 UTC, bordfeldt
Details
More icons are affected\Table column (67.40 KB, image/jpeg)
2016-02-12 13:56 UTC, exxonse
Details

Note You need to log in before you can comment on or make changes to this bug.
Description exxonse 2016-02-11 16:44:36 UTC
Created attachment 122541 [details]
The icons for cut, copy, paste, undo and restore are after updating to 5.1.0.3 only gray boxes

The icons for cut, copy, paste, undo and restore are after updating to 5.1.0.3 only gray boxes
If i revert to version 5.0.4, i have no problem.
A fresh installation of Version 5.1.0.3 did not solve the problem

My Sys

Microsoft Windows 10 Pro Edition (build 10586), 64-bit (10.0.10586)
VGA Driver Nvidia 361.75 
Resolution 3840*2160
I've also changed the resolution. The problem has not been solved
Comment 1 bordfeldt 2016-02-11 18:17:30 UTC
Created attachment 122545 [details]
strange icons
Comment 2 bordfeldt 2016-02-11 18:21:11 UTC
Hello,

for me the same problem after updating from 5.0.4 to 5.1.0. Nearly all icons are affected in all icon sets. I think this is not a minor bug.

My system: Windows 10 Pro on Surface 4 Pro
Comment 3 exxonse 2016-02-12 13:56:46 UTC
Created attachment 122577 [details]
More icons are affected\Table  column
Comment 4 exxonse 2016-02-12 16:10:09 UTC
The icons cannot be exchanged . It loads always the gray box.
If you deactivate and activate an affected Icon, it loads for 0.5. sec.
Then comes the gray box again.
Comment 5 Buovjaga 2016-02-15 13:31:49 UTC
Disable Tools - Options - LibO - View - Use OpenGL for all rendering and restart LibO.

Paste here the contents of your:
C:\Users\User\AppData\Roaming\LibreOffice\4\cache\opengl_device.log

This means both of you, exxonse and bordfeldt

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 6 exxonse 2016-02-15 15:27:59 UTC
opengl_device.log:

DriverVersion: 10.18.13.6175
DriverDate: 1-22-2016
DeviceID: PCI\VEN_10DE&DEV_13C0&SUBSYS_29833842&REV_A1
AdapterVendorID: 0x10de
AdapterDeviceID: 0x13c0
AdapterSubsysID: 0x29833842
DeviceKey: System\CurrentControlSet\Control\Video\{ACF4351F-E950-4F88-BDF3-DCA0D8201972}\0000
DeviceString: NVIDIA GeForce GTX 980
Comment 7 Buovjaga 2016-02-15 18:12:05 UTC
exxonse: just to clarify: does the problem go away, if you disable OpenGL?
Comment 8 exxonse 2016-02-15 18:27:12 UTC
The deactivation of OpenGL solves the problem. 
All icons are now displayed correctly.

Thanks for the hint
Comment 9 Michael Meeks 2016-02-16 10:33:07 UTC
Quite probably this is a dup of bug#97816 which is fixed for 5.1.1 RC2 - what theme are you using ? and can you re-test with OpenGL enabled vs. a master build ? =) Thanks !
Comment 10 Buovjaga 2016-02-16 10:36:37 UTC
Here is the freshest master build: http://dev-builds.libreoffice.org/daily/master/Win-x86@42/current/

It will install separately, it will not mess with your existing stable version.
Comment 11 exxonse 2016-02-16 12:08:34 UTC
I use the normal look without themes
icon style is tango (Here it makes no difference, each style creates the icon error)

The dev build 5.2 (OpenGL on) works without problems (all icons are fine) !!!
Comment 12 Buovjaga 2016-02-16 12:17:44 UTC
Ok, let's close as dupe.
Thanks for testing.

*** This bug has been marked as a duplicate of bug 97816 ***