Download it now!
Bug 97768 - working with onscreen-keyboard LO misunderstands AltGr+E (Euro) as Alt+E
Summary: working with onscreen-keyboard LO misunderstands AltGr+E (Euro) as Alt+E
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0
Keywords: bibisectRequest, regression
: 101770 (view as bug list)
Depends on:
Blocks: Shortcuts-AltGR
  Show dependency treegraph
 
Reported: 2016-02-11 18:50 UTC by bordfeldt
Modified: 2018-02-05 01:23 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bordfeldt 2016-02-11 18:50:48 UTC
LO 5.1.0, first appeared in 5.0.4 on Windows 10 pro on a surface 4 pro.
Working in tablet-mode with the onscreen-keyboard LO interprets an AltGr+E (Euro) as an Alt+E-Shortcut.
Comment 1 Aron Budea 2016-07-12 05:57:13 UTC
Confirmed in Windows 7 with on-screen keyboard. In 5.2.0.2 and master builds it brings up extension manager, but that isn't correct, either.

It's interesting how the behavior is somewhat opposite compared to bug 100622 (it seems that the keyboard and on-screen keyboard are treated differently). I wonder if the changes in bug 95761 are related. Juergen, can you take a look?
Comment 2 Juergen Funk (CIB) 2016-07-12 09:21:32 UTC
Hi Aron,

sorry i have not a tablet, but i think the onscreen-keyboard make not a different between the right and left ALT-KEY.
In windows when the ALTGR-Key is available, then windows send the RIGHT-ALT-CTRL.
Now you can test with the RIGHT-ALT and press the CTRL, but i think here ist the ALT-KEY always the left.
Comment 3 Aron Budea 2016-07-13 02:23:55 UTC
Hi Juergen,

It seems to me that it does. I'm testing with two keyboard layouts, US and United States International (first has double Alts, second has Alt+AltGr), and with US both Alts light up, but with the other one only the respective ones.

What I find unusual is that when I debug into the code when pressing AltGr with the International layout, the VK_CONTROL IF branch is executed, but VK_RMENU isn't. I was thinking it could be because key presses are difficult to debug (since I'm not pressing anything during debugging), but the paths for different key presses are consistent. Unfortunately I can't debug key combinations, but so far I've only tested single modifiers.
Comment 4 Juergen Funk (CIB) 2016-07-13 07:55:26 UTC
Hi Aron,

i think it is not independent of the physical Keyboard, but of the Language.
The other side it is a different handling between Writer and Calc.

I have made a lot of tests with writer and calc with LO 5.0.6 under Windows 7

writer:
-------
  German
   - ALTGR      e  -> €
   - ALTGR-CTRL e  -> €
   - ALT        e  -> menue "Einfügen" or defined hot-key
   - ALT-CTRL   e  -> menue "Einfügen" or defined hot-key

  English 
   - ALTGR      e  -> e
   - ALTGR-CTRL e  -> nothing
   - ALT        e  -> menue "Einfügen" or defined hot-key
   - ALT-CTRL   e  -> nothing or defined hot-key
 

calc:
-----
  German
   - ALTGR      e  -> €
   - ALTGR-CTRL e  -> €
   - ALT        e  -> menue "Einfügen" or defined hot-key
   - ALT-CTRL   e  -> € the defined hot-key ignore

  English 
   - ALTGR      e  -> e
   - ALTGR-CTRL e  -> nothing
   - ALT        e  -> menue "Einfügen" or defined hot-key
   - ALT-CTRL   e  -> nothing or defined hot-key

Calc has her own key-handler, i hope it helps
For debugging it is better you make debug-outputs
Comment 5 bordfeldt 2016-08-03 16:22:25 UTC
still exists in 5.2.0.4

AltGR+E is interpreted as Strg(Ctrl)+Alt+E
Comment 6 Aron Budea 2016-08-29 00:47:51 UTC
*** Bug 101770 has been marked as a duplicate of this bug. ***
Comment 7 Xisco Faulí 2016-09-13 10:27:19 UTC
Since we have a bibisect repository for windows covering the branch where this regression was introduced, adding keyword 'bibisectRequest'.
More info: https://wiki.documentfoundation.org/QA/Bibisect/Windows
Comment 8 bordfeldt 2017-02-13 18:03:06 UTC
still exists in 5.3.0.3

AltGR+E is interpreted as Strg(Ctrl)+Alt+E
Comment 9 bordfeldt 2018-02-04 15:25:10 UTC
just tested with LO 6.0.0.3 problem seems to be fixed
Comment 10 Aron Budea 2018-02-05 01:23:41 UTC
Must have been resolved by the commit in bug 95761 comment 10 (which reverted the earlier commit). Let's close this as fixed.