Bug 97770 - pdf render is very bad
Summary: pdf render is very bad
Status: CLOSED DUPLICATE of bug 91252
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-11 19:32 UTC by ilianus
Modified: 2016-02-16 18:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
fontwork (184.10 KB, image/jpeg)
2016-02-11 19:32 UTC, ilianus
Details
shape (152.03 KB, image/jpeg)
2016-02-11 19:32 UTC, ilianus
Details
enhancement (161.93 KB, image/jpeg)
2016-02-16 12:42 UTC, ilianus
Details
svg affected (90.25 KB, image/jpeg)
2016-02-16 17:42 UTC, ilianus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ilianus 2016-02-11 19:32:04 UTC
Created attachment 122548 [details]
fontwork

hi programmers

i think that pdf render needs some love, it doesn't behave well.
Comment 1 ilianus 2016-02-11 19:32:47 UTC
Created attachment 122549 [details]
shape
Comment 2 m.a.riosv 2016-02-11 23:49:43 UTC
Please can you set up your LibreOffice version and your Operating system.

And also attach a sample file to generate the pdf.

What are you Menu/File/Export as PDF - Image options?
Comment 3 ilianus 2016-02-15 20:10:36 UTC
all the versions

all the OS

it is easy to reproduce the bug (just use the pdf render)
Comment 4 V Stuart Foote 2016-02-15 20:38:08 UTC
As OP seems reluctant to provide version details (from Help -> About) dialog, no qualms setting as duplicate of bug 96653,  although bug 97337 might also be in play.

*** This bug has been marked as a duplicate of bug 96653 ***
Comment 5 V Stuart Foote 2016-02-15 21:22:33 UTC
The moire pattern of the radial gradient applied Fontwork on export to PDF is legitimate, but is a duplicate of bug 91252 - Radial gradient exported as path instead of gradient in PDF -- where export to PDF and EPS both suffer from radial gradient interference and moire.
Comment 6 ilianus 2016-02-16 12:42:04 UTC
Created attachment 122682 [details]
enhancement
Comment 7 ilianus 2016-02-16 12:56:08 UTC
enhancement in FONTWORK but the steps persist (version 5.0.2.5)
Comment 8 V Stuart Foote 2016-02-16 13:36:10 UTC
Hmmm, so of the two issues to diagonal tearing of bug 96653 is resolved.

The second, poor quality rendering of gradient (radial and square) in PDF resulting in moire interference patterns is bug 91252

adjusting summary there and adding test documents.

*** This bug has been marked as a duplicate of bug 91252 ***
Comment 9 ilianus 2016-02-16 17:42:22 UTC
Created attachment 122694 [details]
svg affected

it seems that the SVG is affected by this bug
Comment 10 ilianus 2016-02-16 17:51:48 UTC
i used deferent externet renderds "cups", "Ms xps", "pdf printer" i thought that I can get around the bug but no way it persists
Comment 11 V Stuart Foote 2016-02-16 18:04:58 UTC
@ilanus please post to bug 91252 you are losing details that should be recorded there. 

This bug is closed.

*** This bug has been marked as a duplicate of bug 91252 ***