Bug 97774 - From Tools SQL - Insert Works in Windows not on Linux – easily reproducible.
Summary: From Tools SQL - Insert Works in Windows not on Linux – easily reproducible.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0 target:5.2.0
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-11 21:02 UTC by Michael
Modified: 2016-10-25 18:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2016-02-11 21:02:40 UTC
Downloaded  odb39-Before.odb from http://thefrugalcomputerguy.com/libreoffice-base/index.php

Copied table tbl_Employees to tbl_Employees-orig

Go into Tools Relationships and delete the two relationships.

Copy/paste SQL text from http://www.thefrugalcomputerguy.com/libreoffice-base/downloads/odb39a-Create-Employees-Table.txt 
into SQL and execute completes successfully on both versions

Copy/paste text from http://www.thefrugalcomputerguy.com/libreoffice-base/downloads/odb39b-Insert-From-Select-with-Case.txt 
into SQL and execute – Windows version successfully executes Linux version fails.

Windows 7 – LibreOffice Base 5.0.4.1  
Linux Mint 17.3 – LibreOffice Base 5.0.3.2
Comment 1 Dennis 2016-02-12 11:36:58 UTC
I can confirm
Version: 5.1.0.3
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Linux 3.19; UI Render: default; 
Locale: en-US (en_US.UTF-8)

INSERT INTO via tools>SQL =fail
Comment 2 Buovjaga 2016-02-15 13:17:34 UTC
NEW per comment 1
Comment 3 Julien Nabet 2016-04-28 20:43:08 UTC
I can't give it a try because of tdf#97854 (crash when deleting a relationship).
Comment 4 Caolán McNamara 2016-05-26 11:17:37 UTC
Comment #1 says "Copied table tbl_Employees to tbl_Employees-orig" but the sql of odb39b-Insert-From-Select-with-Case.txt says "tbl_Employees-Original"

Now that I've fixed tdf#97854 if I copy tbl_Employees to tbl_Employees-Original, delete the references and do the rest of the sql statement copy paste execute I get two successfully executed status returns.