Bug 97822 - Trees missing arrows if OpenGL is enabled
Summary: Trees missing arrows if OpenGL is enabled
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.3.0 target:6.2.4
Keywords:
Depends on:
Blocks: OpenGL-Linux
  Show dependency treegraph
 
Reported: 2016-02-12 21:40 UTC by Andreas B.
Modified: 2019-04-16 11:42 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot 1: OpenGL Off, all OK (103.55 KB, image/png)
2016-02-12 21:40 UTC, Andreas B.
Details
Screenshot 2: OpenGL On, Tree missing arrows (103.10 KB, image/png)
2016-02-12 21:41 UTC, Andreas B.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas B. 2016-02-12 21:40:40 UTC
Created attachment 122596 [details]
Screenshot 1: OpenGL Off, all OK

If OpenGL is enabled, the Arrows are missing in the Settings Tree.

See Screenshots attached.

System is Ubuntu 14.04.3 LTS.
Graphics Card is: VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
Comment 1 Andreas B. 2016-02-12 21:41:36 UTC
Created attachment 122597 [details]
Screenshot 2: OpenGL On, Tree missing arrows
Comment 2 Andreas B. 2016-02-12 21:50:20 UTC
If you open the two screenshots in two browser tabs, and switch them, you can see there are also another small differences:

- The spinner button are one pixel higher
- The spinner border at the Bottom is now 2px
I tested it again: It's not reproducible, now the Spinner is looking right in OpenGL Mode.


Some text are underlined (Key Shortcuts, this was because I pressed ALT+PRT SC)
I played some time with the ALT key, I could reproduce it: Once the line is not removed in OpenGL mode, so this is may a repaint problem. But I'm not sure is this is an OpenGL Problem...


So I would focus on the Tree: This problem is reproducible on my system.
Comment 3 tommy27 2016-02-14 07:04:17 UTC
works fine with the same release under Win8.1 x64
so, probably a Linux only bug
Comment 4 V Stuart Foote 2016-02-17 02:21:01 UTC
@Andreas B. please post version detail copied from Help -> About and also post text from the opengl_device.log in the user profile cache.

@Tor, if legitimately a 5.1.0.3 build, should this be a dupe of bug 95813 and reopen?
Comment 5 Michael Meeks 2016-02-17 14:40:45 UTC
Confirmed; doesn't work for me under gtk2' however - splitting this out to the Linux / OpenGL tracker - since this works fine for me under windows =)
Comment 6 Andreas B. 2016-02-17 16:39:38 UTC
Version: 5.1.0.3
Build-ID: 1:5.1.0~rc3-0ubuntu1~trusty0
CPU Threads: 8; OS Version: Linux 3.13; UI Render: GL;

~/.config/libreoffice/4/cache is empty.
Do I have to do something to enable the OpenGL Log?

I'm using Linux, not Windows, Googled, and found that the log is created in the Win implementation?

in WinOpenGLDeviceInfo::isDeviceBlocked()
Comment 7 Tor Lillqvist 2016-05-13 12:47:27 UTC Comment hidden (obsolete)
Comment 8 Tor Lillqvist 2016-05-13 12:48:26 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2017-05-22 13:38:41 UTC Comment hidden (obsolete)
Comment 10 Gerry 2017-08-18 19:02:30 UTC
I encounter exactly the same problem. I don't see the arrows if OpenGL is switched on.

LibreOffice:
Version: 5.4.0.3
Build-ID: 1:5.4.0~rc3-0ubuntu0.16.04.1~lo1
CPU-Threads: 4; Betriebssystem:Linux 4.4; UI-Render: GL; VCL: gtk2; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: single

System: Ubuntu Gnome 16.04.3 LTS 64-Bit 
Processor: Intel® Core™ i3-3120M CPU @ 2.50GHz × 4 
Graphics: Intel® Ivybridge Mobile
Comment 11 QA Administrators 2018-08-19 02:36:56 UTC Comment hidden (obsolete)
Comment 12 Miklos Vajna 2019-04-11 09:58:00 UTC
I can reproduce this, I plan to take a look.
Comment 13 Commit Notification 2019-04-13 10:35:39 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/fb9c7e31f888a301fecb5257635e12ce7b907d14%5E%21

tdf#97822 vcl opengl gtk2: fix missing list node widget

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Miklos Vajna 2019-04-15 07:49:20 UTC
SAL_USE_VCLPLUGIN=gtk SAL_FORCEGL=1 ./soffice is needed on Linux to test this, since GL is off by default and gtk3 is normally used instead of gtk.
Comment 15 Commit Notification 2019-04-15 09:48:49 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/b0da0a45a6453a0ddebded83ae8401e7f3cccde3%5E%21

Related: tdf#97822 vcl opengl gtk2: fix missing slider widget

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2019-04-16 11:42:33 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/eeb9e6bfdb6f8d4e3edbd142c8ef129421d4b93f%5E%21

tdf#97822 vcl opengl gtk2: fix missing list node widget

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.