Download it now!
Bug 97840 - EDITING: table's or field's name does'n get updated in the forms
Summary: EDITING: table's or field's name does'n get updated in the forms
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Database-Forms
  Show dependency treegraph
 
Reported: 2016-02-13 17:47 UTC by boicottms
Modified: 2017-11-02 23:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description boicottms 2016-02-13 17:47:25 UTC
When I change a field's or a table's name, an existing form is not updated, so its fields have to be edited one by one or re-created.
Strangely enough, the labels created with the wizard are updated.
To reproduce:
1. create a table with some fields
2. create a form with the wizard with all the fields
3. change the name of the table or some of the fields
4. the form labels are updated, not the fileds queries.
I would expect every reference to the updated name shall update to keep things working.
Comment 1 Buovjaga 2016-02-16 16:44:14 UTC
Yep, it says "The data content could not be loaded. There exists no table named "Tasks"." after I changed the table named and tried to open the form.

Win 7 Pro 64-bit, Version: 5.1.0.3 (x64)
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)
Comment 2 Robert Großkopf 2016-02-16 18:13:26 UTC
This never worked as expected here. There isn't defined a reference like: if you change this, change also the other name. References, like they are defined for a database, won't let you change the name of a table, where a reference is made to.

The wished behavior is an ask for an enhancement. So I will change the importance to this.