Bug Hunting Session
Bug 97876 - Home/End Keys not working
Summary: Home/End Keys not working
Status: RESOLVED DUPLICATE of bug 91909
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-15 15:08 UTC by Tom B
Modified: 2016-02-16 21:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom B 2016-02-15 15:08:56 UTC
This seems to have been introduced between 5.0 and 5.1. Pressing the Home or End key should (and used to) move the cursor to the start/end of the current line.

This still works in Writer, however, in Impress, Home/End has stopped working entirely. Pressing them has no effect. page up/page down keys still work as expected.
Comment 1 V Stuart Foote 2016-02-15 16:58:17 UTC
Can not confirm

On Windows 10 Pro with
Version: 5.1.1.1 (x64)
Build ID: c43cb650e9c145b181321ea547d38296db70f36e
CPU Threads: 8; OS Version: Windows 6.19; UI Render: default; 
Locale: en-US (en_US)

Version: 5.0.2.2
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: en-US (en_US)

Don't have a 5.1.0.3 install at the moment--if anyone else wants to check.

STR:

1. open new Impress document
2. take title slide default
3. click and enter text in title
4. click and enter text in text box
5. navigate to title
6. <end> key move to end of title?
7. <home> key move to beginning of title?
8. navigate to text box
9 add multi lines of text
10. cursor key navigate between lines
11. <home> key move to beginning of line?
12. <end> key move to end of line
13. change line repeat moves beginning/end

Seems to work correctly.
Comment 2 raal 2016-02-15 19:52:09 UTC
I can not confirm with Version: 5.2.0.0.alpha0+
Build ID: 91a7580e03d5b47c6e2513afce85ddee45e730b6
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-04_00:17:43
Comment 3 Maxim Monastirsky 2016-02-16 21:46:25 UTC
Fixed by Caolán in https://cgit.freedesktop.org/libreoffice/core/commit/?id=758a50110aae8c0b339e3230b39f8d8343ce6bbc but was too late for 5.1.0.3

*** This bug has been marked as a duplicate of bug 91909 ***