Bug 97909 - some custom animations not working
Summary: some custom animations not working
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-16 17:00 UTC by David H
Modified: 2016-04-29 12:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
list of working animations (131 bytes, text/plain)
2016-02-17 15:43 UTC, David H
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David H 2016-02-16 17:00:58 UTC
boomerang, bounce, spin in and many more animations do not work.
Had no issues with 5.0.4.2
Comment 1 Buovjaga 2016-02-17 12:55:26 UTC
Repro in 5.1, but not in 5.2.

Could you test with 5.1.1 release candidate to see, if it is fixed already in it? Then you could set to RESOLVED WORKSFORME, if it works.

Fot testers: boomerang, bounce are in category Exit - Exciting. I was unable to locate spin in and did not feel like wasting more time hunting for it.

Win 7 Pro 64-bit, Version: 5.1.0.3 (x64)
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha0+
Build ID: a6f876d45bd4e41a7143594a6cb11b6893a0f620
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-11_00:07:38
Locale: fi-FI (fi_FI)
Comment 2 David H 2016-02-17 15:43:55 UTC
Created attachment 122735 [details]
list of working animations
Comment 3 David H 2016-02-17 15:48:41 UTC
tested in 5.1.1.rc1-no change
Comment 4 Buovjaga 2016-02-18 08:43:18 UTC
Ok, let's set to NEW and revisit as further release candidates of 5.1.1 are released.
Comment 5 ullix 2016-04-05 14:04:23 UTC
Using libreoffice 
Version: 5.1.2.2
Build-ID: 1:5.1.2~rc2-0ubuntu1~trusty0
CPU-Threats: 8; BS-Version: Linux 4.4; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE.UTF-8)
on Ubuntu 14.04

not working even for the BASIC Fly-in, or Moderate ZOOM, and other animations, apparently those which move the object.

Working are things which leave the obect in place, like Wipe.

Every non-working animation looks like Appear.
Comment 6 Buovjaga 2016-04-08 11:54:44 UTC
ullix: could you try with 5.2? They all work for me.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.0.0.alpha0+
Build ID: 9b0069c2833313ba9fab91f45edd354ba334f94b
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on April 8th 2016
Comment 7 ullix 2016-04-09 17:55:30 UTC
I would if I'd knew from where to install it. I need a ppa for Ubuntu and even the LibreOffice Pre-Releases have only 5.1.1-rc ?

I need to give a presentation soon, and some of my carefully designed animations simply don't work :-(
Comment 8 Buovjaga 2016-04-10 12:54:39 UTC
http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@70-TDF/current/

After extracting, you can use a script from here to install it in parallel: https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Comment 9 ullix 2016-04-10 18:09:46 UTC
Followed your steps and - Hooray -  all animations worked the way they should!

Now, can you bring this into the stable 5.1 version? I feel a bit uneasy with alpha when doing a presentation to an auditorium.
Comment 10 David H 2016-04-22 16:45:36 UTC
Tested in 5.2-alpha1
All animations now function.
Comment 11 David F Smith 2016-04-28 17:48:15 UTC
(In reply to ullix from comment #9)
> Followed your steps and - Hooray -  all animations worked the way they
> should!
> 
> Now, can you bring this into the stable 5.1 version? I feel a bit uneasy
> with alpha when doing a presentation to an auditorium.

Ullix, if this is still an issue for you, you can drop back to 5.0.5 ("Still").  I was about to report the same bug you found in 5.1.1, and all of the animations worked correctly in 5.0.5.
Comment 12 ullix 2016-04-29 12:18:08 UTC
David,

thanks for the idea - but it did not work.

I have now ubuntu-mate 16.04, and after activating the ppa for the 5.0* version libreoffice could not be forced to the 5.0* version. Even after removing all traces of libreoffice, attempting to force any file to that old version resulted in either an immidiate removal of the installation mark, or in broken dependiencies.

I then removed the ppa and the latest version 5.1.2 could be installed without any problem.

Don't know where the problem ist - is it the 16.04 Ubuntu Mate version, or am I doing it something incorrectly?

Really hoping for an update soon :-/