Bug 97940 - Printing of logo (fine lines) corrupted
Summary: Printing of logo (fine lines) corrupted
Status: RESOLVED DUPLICATE of bug 96653
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-17 15:34 UTC by putt1ck
Modified: 2016-03-10 07:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
ODT document with logo (22.22 KB, application/vnd.oasis.opendocument.text)
2016-02-17 15:34 UTC, putt1ck
Details
PDF version of document with logo correct from LO5.0 (43.86 KB, application/pdf)
2016-02-17 15:35 UTC, putt1ck
Details
PDF version of document with logo distorted from LO5.1 (43.94 KB, application/pdf)
2016-02-17 15:36 UTC, putt1ck
Details
PDF export of Draw doc with different versions of logo (29.69 KB, application/pdf)
2016-02-17 16:03 UTC, putt1ck
Details

Note You need to log in before you can comment on or make changes to this bug.
Description putt1ck 2016-02-17 15:34:28 UTC
Created attachment 122732 [details]
ODT document with logo

When printing or exporting PDF, logo is corrupted. Visually this looks like diagonal white stripes through it, but the lines remaining visible are also wrong (thickened). The logo was created 5 years ago and has been used without issue in OpenOffice/LibreOffice ever since.

Attached is an odt created in LO5.0, with a PDF export of the same from both LO5.0 and LO5.1 to show differences in output. For testing I also cut and paste the logo into a LO5.1 Draw document with the same output issue.

Version details for computer with issue:

Version: 5.1.0.3
Build ID: 10m0(Build:3)
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
Locale: en-GB (en_GB.UTF-8)

(openSUSE Tumbleweed, patched to Feb 16th)

The machine without issue is also Tumbleweed but not updated for 6 weeks.
Comment 1 putt1ck 2016-02-17 15:35:36 UTC
Created attachment 122733 [details]
PDF version of document with logo correct from LO5.0
Comment 2 putt1ck 2016-02-17 15:36:52 UTC
Created attachment 122734 [details]
PDF version of document with logo distorted from LO5.1
Comment 3 putt1ck 2016-02-17 16:03:49 UTC
Created attachment 122736 [details]
PDF export of Draw doc with different versions of logo

Further testing suggests it's something to do with the format of the image used for the logo. Attached is a PDF of a Draw doc with 3 versions of the logo. Bottom is it as cut and paste direct from a Writer doc, middle is a copy of the same converted to a bitmap and top is a cut and paste from the PDF produced LO5.0 - so maybe same bug as https://bugs.documentfoundation.org/show_bug.cgi?id=96653
Comment 4 Buovjaga 2016-02-20 15:07:39 UTC
This is probably fixed in 5.1.1 RC1. Could you try it? https://wiki.documentfoundation.org/Installing_in_parallel/Linux

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED DUPLICATE of bug 96653, if the problem went away.
Comment 5 Dale 2016-03-10 03:29:20 UTC
Windows 7:
Problem exists in 5.1.0.3
Does not exist in 5.1.1.3
Seems like it is fixed.
Comment 6 Buovjaga 2016-03-10 07:38:36 UTC

*** This bug has been marked as a duplicate of bug 96653 ***