Download it now!
Bug 97980 - SVG: Graph data series filled colors being cropped
Summary: SVG: Graph data series filled colors being cropped
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bisected, filter:svg
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2016-02-18 14:09 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-03-09 07:15 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
before and after (120.42 KB, image/png)
2016-02-18 15:10 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-02-18 14:09:39 UTC
Steps:
1) Open Writer
2) Insert https://dev.w3.org/SVG/tools/svgweb/samples/svg-files/displayWebStats.svg
3) Notice that the graph's blue and yellow data series are being cropped off

Regression as this worked correctly 2 weeks ago.

Version: 5.2.0.0.alpha0+
Build ID: 72720ac9b934af6f84111ec694fa46555d10a7bd
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-17_19:06:34
Locale: en-US (en_US.UTF-8)

Version: 5.2.0.0.alpha0+
Build ID: 513d5c5781ec14f8512432f31290a3d54c8d57df
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-01_10:25:20
Locale: en-US (en_US.UTF-8)
Comment 1 Xisco Faulí 2016-02-18 14:38:40 UTC
Hi Jay,
Could you please point where the problem is? I can't see it.
Comment 2 Yousuf Philips (jay) (retired) 2016-02-18 15:10:39 UTC
Created attachment 122771 [details]
before and after
Comment 3 Xisco Faulí 2016-02-18 15:34:41 UTC
Hi Jay,

it looks to be related to Linux only, I can't reproduce it in

Version: 5.2.0.0.alpha0+
Build ID: dc9ec9f359ddc91a3aedbe38e6079b0555fb03f9
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-17_00:35:04
Locale: es-ES (es_ES).

but I do in

Version: 5.2.0.0.alpha0+
Build ID: 2966d57bdfdd40a55e31408f7da75b415e809d8e
CPU Threads: 1; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-18_00:09:33
Locale: en-US (en_US.UTF-8)

Maybe a vcl regression?
Comment 4 raal 2016-02-19 07:54:04 UTC
Bibisect with Linux_debug-repo shows it should be bug from 16.2.2016, but I don't see obvious commit - Xisco could you look at the commit from 16.2.?
Comment 5 Xisco Faulí 2016-02-19 08:02:23 UTC
Hi raal, this is weird because Jay could reproduce it in a build from 2016-02-01_10:25:20
Comment 6 Xisco Faulí 2016-02-23 18:31:51 UTC
Regression introduced by 4d1c24a3aef15979ac5a4292ea5ff8028a5df112
Comment 7 Xisco Faulí 2016-02-23 18:36:18 UTC
Sorry, regression introduced by 7b7ffedfa6357b902a5e354d986dac39a3b2f462
Comment 8 Xisco Faulí 2016-02-29 23:41:37 UTC
Fixed by 85fcf15ff41ceb95f46dee586ff7187551be4955
Comment 9 Yousuf Philips (jay) (retired) 2016-03-09 07:15:35 UTC
Version: 5.2.0.0.alpha0+
Build ID: ed51d4293dd919a03edca11ec48c607bbfa31076
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86@71-TDF, Branch:master, Time: 2016-03-07_00:33:34
Locale: en-US (en_US.UTF-8)