Bug 98001 - File/New, Recent documents, Wizards cannot be disabled
Summary: File/New, Recent documents, Wizards cannot be disabled
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.0.6
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-19 10:03 UTC by Oliver Specht (CIB)
Modified: 2019-12-03 14:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
example to disable menu commands (12.84 KB, application/vnd.oasis.opendocument.text)
2016-02-19 10:03 UTC, Oliver Specht (CIB)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Specht (CIB) 2016-02-19 10:03:12 UTC
Created attachment 122793 [details]
example to disable menu commands

With interception of commands it is possible to disable actions via UNO API.
This can be achieved via the interface com::sun::star::frame::XDispatchProviderInterception

This works for almost all commands but not for those that get a sub menu added programmatically in the framwork module.

The button "Intercept menu entries" in the attached document disables commands related to the following menu entries.

Window/New Window

File/New
File/Wizards
File/Recent Documents

While the first one is actually disabled, the others are not. Please note that the toolbox button executing 'New' _is_ disabled.

With the button "Undo changes" the interceptor is removed.
Comment 1 Oliver Specht (CIB) 2016-02-19 10:30:57 UTC
This already fixed in master with commit a6e8910a3c5d33e671a13559438b7228596b8bca
Comment 2 Commit Notification 2016-02-19 12:16:47 UTC
Oliver Specht committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8a50946c2868f196a1f4571e491a5ca7fb12492a&h=libreoffice-5-0

tdf#98001: allow disabling file/new, wizards, recent documents menu entries

It will be available in 5.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 raal 2016-03-18 22:25:39 UTC
Oliver, what versions 5.1 and 5.2?
Comment 4 Aron Budea 2016-06-29 02:28:17 UTC
So, it seems to work in 5.2.0.1, but not in 5.1.4.2, so it's not yet in 5.1.
I also noticed in 5.2.0.1, File->New doesn't get enabled after Undo, not sure why that is.
Comment 5 Xisco Faulí 2016-09-15 22:43:19 UTC
Hello,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 6 Aron Budea 2016-09-19 23:09:18 UTC
Not sure what's going on inside, but undo still doesn't enable File -> New and File -> Wizards. That doesn't seem to be okay... or is it?
Comment 7 QA Administrators 2017-12-01 11:55:08 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2019-12-03 14:57:46 UTC
Dear Oliver Specht (CIB),

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug