Bug Hunting Session
Bug 98098 - Thesaurus incorrect
Summary: Thesaurus incorrect
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-23 00:22 UTC by itz_silence
Modified: 2017-01-03 14:50 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
hoping + hopping are in the en_GB dictionary forked by me (38.09 KB, image/png)
2016-05-18 23:23 UTC, Marco A.G.Pinto
Details
each word works independently from the .DIC (25.76 KB, image/png)
2016-05-18 23:44 UTC, Marco A.G.Pinto
Details
synonyms for hoping with LO 5.1.3 dictionary (64.00 KB, image/png)
2016-05-18 23:48 UTC, Aron Budea
Details
Fixed: hop + hope in Thesaurus (5.86 MB, application/vnd.openofficeorg.extension)
2016-05-19 00:24 UTC, Marco A.G.Pinto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description itz_silence 2016-02-23 00:22:59 UTC
I'm using the standard English (USA) thesaurus in Writer and Calc. Apparently, the thesaurus thinks the word hoping means jumping (when it actually means wishing), while the word hopping (which does mean jumping) does not exist. I would have thought at least a word processor would get this right. This reduces my confidence in this product.
Comment 1 Buovjaga 2016-03-02 19:25:55 UTC
I installed mythes-en  20060306-3 package.

In Writer, had lang of text in English (US), wrote hoping, selected it and Tools - Thesaurus.

No alternatives found.

Checked that Thesaurus works OK for some other words.

Was the thesaurus pre-installed for you, or did you install it yourself? Which package is it?

64-bit, KDE Plasma 5
Build ID: 5.1.0.3 Arch Linux build-1
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 2 Aron Budea 2016-05-18 04:28:38 UTC
Results with 5.1.3.2.

Builtin thesaurus:
-hoping -> anticipation, expectancy, feeling etc.
-hopping -> (none)

English Dictionaries extension's thesaurus:
-hoping -> jump, jumping, hops, vine etc.
-hopping -> (none)

Marco, can you look into it, and fix it in the maintained dictionary?
Comment 3 Aron Budea 2016-05-18 04:52:05 UTC
My bad, Kevin Atkinson is maintaining the US dictionary.

Kevin, what's the best way of reporting issues with it?
Comment 4 Kevin Atkinson 2016-05-18 05:17:18 UTC
(In reply to Aron Budea from comment #3)

> My bad, Kevin Atkinson is maintaining the US dictionary.
> 
> Kevin, what's the best way of reporting issues with it?

I do not maintain the thesaurus, just the dictionary.

For the dictionary https://github.com/kevina/wordlist/issues
Comment 5 Marco A.G.Pinto 2016-05-18 09:49:12 UTC
Aron: Hello!

The Thesaurus was created by Daniel Naber from LanguageTool.

I once asked him if he could update it but he said he didn't have free time to do it.

What I have done was to convert it into UTF-8 and delete the hundreds(?) of duplicates.

To edit it, one could use my tool:
Proofing Tool GUI:
http://marcoagpinto.cidadevirtual.pt/proofingtoolgui.html

Or send me an e-mail in private or here and tell me detailed information of what you want changed.

Thanks!
Comment 6 Aron Budea 2016-05-18 22:49:33 UTC
Kevin, Marco, thanks for your reply and for working on the dictionaries.
We have a few reported issues related to the English dictionary, I'll be forwarding those via github.

(In reply to Marco A.G.Pinto from comment #5)
> Or send me an e-mail in private or here and tell me detailed information of
> what you want changed.

I'm afraid I don't know anything about the dictionary/thesaurus, and how to work with them. In this case (comment 2 with my observations) my guess is that the suggestions are correct, but the stem isn't identified properly (finds "hop" for "hoping" and nothing for "hopping").
Could it be that the switches for affixes are not correct in the dictionary?

current: hope/28	1
new:     hope/MS

For "hope" these are the relevant lines in the two dictionaries, but I don't know what the number stands for, and have trouble identifying what "MS" exactly is, even based on the affixes description.
A wild guess: could it be that "hope" is only given as a noun there, and not as a verb?

No clue about "hop."
Comment 7 Marco A.G.Pinto 2016-05-18 23:23:02 UTC
Created attachment 125160 [details]
hoping + hopping are in the en_GB dictionary forked by me

hoping + hopping are in the en_GB dictionary forked by me
Comment 8 Marco A.G.Pinto 2016-05-18 23:44:23 UTC
Created attachment 125161 [details]
each word works independently from the .DIC

each word works independently from the .DIC
Comment 9 Aron Budea 2016-05-18 23:48:52 UTC
Created attachment 125162 [details]
synonyms for hoping with LO 5.1.3 dictionary
Comment 10 Marco A.G.Pinto 2016-05-19 00:24:20 UTC
Created attachment 125163 [details]
Fixed: hop + hope in Thesaurus

It is fixed in the British speller.

You can now test it.

Please notice that en_GB is here for test only as only on 1-JUN-2016 it will be officially updated.

You can use the Thesaurus in LO since it is the most recent version converted to UTF-8 and hundreds of repeated lines removed (replace the current one with this)
Comment 11 Aron Budea 2016-05-19 02:28:06 UTC
Submitted the bug to the US dictionary's issue tracker:
https://github.com/kevina/wordlist/issues/154

Once it's fixed there, it'll first be included in English Dictionaries extension Marco is maintaining (comment 10): http://extensions.libreoffice.org/extension-center/english-dictionaries/

Then eventually it'll hopefully make its way into LO (bug 97393).