Bug 98156 - 'soffice --help': "--convert-to" available filter list not described (and man libreoffice)
Summary: 'soffice --help': "--convert-to" available filter list not described (and ma...
Status: RESOLVED DUPLICATE of bug 98153
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-24 19:07 UTC by Stéphane Aulery
Modified: 2016-03-08 09:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Output of "soffice --help" command (120.35 KB, image/png)
2016-03-06 11:45 UTC, Stéphane Aulery
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stéphane Aulery 2016-02-24 19:07:52 UTC
From: "A. Costa" <agcosta@gis.net>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: libreoffice-common: 'man libreoffice': "--convert-to" available filter list not described.
Date: Tue, 28 Feb 2012 18:08:12 -0500

Package: libreoffice-common
Version: 1:3.4.5-2
Severity: normal

Dear Maintainer,

'man libroffice' mentions converting certain file formats: 

    % man libreoffice | grep -n "\-\-convert\-to" | tail -n +2
    53:       --convert-to output_file_extension[:output_filter_name]  [-outdir  output_dir]
    61:              --convert-to pdf *.doc
    65:              --convert-to pdf:writer_pdf_Export -outdir /home/user *.doc

...the examples indicate 'pdf' works.  'pdf' is the only output 
format cited.

Using a 'ppt' file as input, I've also had success with:

    --convert-to odi
    --convert-to swf

These should all be documented.  

There should also be a way for users to list all possible outputs.
Something like 'mplayer -vo help' would be useful.  The output
list might be made context sensitive relative to the input.

Possible syntax, would be something like:

    loimpress  --convert-to list  /tmp/USCarriers.pps
    
...'list' could show only the formats 'pps' could be partially 
or completely converted to.  It would not show incompatible formats
such as 'xls'.

    loimpress  --convert-to list_all  /tmp/USCarriers.pps

...'list_all' would show all of the filters.  It would show
'xls'.



Hope this helps...
Comment 1 raal 2016-03-06 10:08:30 UTC
man pages
--convert-to  output_file_extension[:output_filter_name] [--outdir out‐
       put_dir] file...
              Batch converts files.  If --outdir is  not  specified  then  the
              current  working  directory  is used as the output directory for
              the converted files. It implies --headless.

              Examples:

              --convert-to pdf *.doc

              Converts all .doc files to PDFs.

              --convert-to pdf:writer_pdf_Export --outdir /home/user *.doc

              Converts all .doc files to PDFs using the settings in the Writer
              PDF export dialog and saving them in /home/user.


AUTHOR
       This manual page was created by Rene  Engelhard  <rene@debian.org>  for
       the  Debian  GNU/Linux  Distribution, because the original package does
       not  have  one.  It   was   updated   for   Novell   by   Petr   Mladek
       <petr.mladek@novell.com>  and  adapted for LibreOffice by Philipp Weis‐
       senbacher <philipp.weissenbacher@gmail.com>.


So as indicated in man pages, LO doesn't create man pages. Closing as notourbug.
Comment 2 Stéphane Aulery 2016-03-06 11:45:16 UTC
Created attachment 123343 [details]
Output of "soffice --help" command
Comment 3 Stéphane Aulery 2016-03-06 11:48:08 UTC
Ok, LO does not provide the man page, but provides detailed output with the command "soffice --help".
Comment 4 Rene Engelhard 2016-03-07 23:13:56 UTC
raal: sorry, not true.

The manpage *INITIALLY* was written by me, yes, and then adapted/extended later etc. And it was and still is part of the LO build.

https://cgit.freedesktop.org/libreoffice/core/tree/sysui/desktop/man
(lowriter etc. is basically links to libreoffice)
Comment 5 Rene Engelhard 2016-03-07 23:15:22 UTC
(well, not the LO build but distro-pack-install, so only distros get it, but LO ships them in the source code.)
Comment 6 raal 2016-03-08 06:30:30 UTC
Thank Rene for informations, setting to new.
Comment 7 Maxim Monastirsky 2016-03-08 09:32:09 UTC
Adding list of all filters to man is overkill (and plain wrong, because filters can change, and man is static). And adding CLI option already covered by Bug 98153.

*** This bug has been marked as a duplicate of bug 98153 ***