Bug 98193 - Save icon breaks icon customization
Summary: Save icon breaks icon customization
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Icon-Themes-Code
  Show dependency treegraph
 
Reported: 2016-02-25 19:43 UTC by Aibara
Modified: 2019-05-16 07:59 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Can't edit the "disk with star" icon. (46.08 KB, image/png)
2016-02-25 19:43 UTC, Aibara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aibara 2016-02-25 19:43:50 UTC
Created attachment 122995 [details]
Can't edit the "disk with star" icon.

I noticed that the save icon in Writer has changed: it is no longer a single icon that is grayed out when there are no changes to the document, but rather one that adds a star when the document has changed and can be saved.

The problem is that this new behavior breaks Writer's customize icon feature:  the user can no longer customize the icon fully, only the "no-changes-yet" state. In order to be consistent, a way to edit the "changes-have-been-made" save icon with a star should be added.

I've changed my icons to be monochrome, but I can find no way to change the new "disk with a star" icon; see attached picture.

Thanks.
Comment 1 Samuel Mehrbrodt (CIB) 2016-02-25 21:19:41 UTC
Which icon theme do you use?
Comment 2 Aibara 2016-02-25 22:21:04 UTC
I just added my own icons (mostly from the Faenza icon set) using Tango as a base via the icon customization option (Tools -> Customize... -> Toolbars -> Modify -> Change Icon). The only way I could change the star icon was to manually switch out /res/savemodified_small.png in images_tango.zip with something else.

In any case, my point was just that having the save icon change to another (instead of just being grayed out when no changes have been made) means that the built-in customize icon function in Writer does not work correctly, since you can only set the one for the "not changed yet" state, and not the "changes have been made" state. Using a non-Tango icon set (like the Human theme) brings up that same icon, but that's a different problem (namely that no one has made a proper Human version of that icon).
Comment 3 Adolfo Jayme 2016-02-26 14:29:22 UTC
> "[…] Using a non-Tango icon set (like the Human
> theme) brings up that same icon, but that's a different problem (namely that
> no one has made a proper Human version of that icon).

That is because Ubuntu will drop the Human theme. See http://pad.lv/1506544
Comment 4 andreas_k 2016-02-26 14:48:32 UTC
nice to read.
Comment 5 Aibara 2016-02-26 19:11:01 UTC
(In reply to Adolfo Jayme from comment #3)
> 
> That is because Ubuntu will drop the Human theme. See http://pad.lv/1506544

Good to hear, I think that theme looks much better. But the problem with the icon customization function remains regardless of the theme.
Comment 6 Samuel Mehrbrodt (CIB) 2016-02-27 11:00:46 UTC
(In reply to Aibara from comment #2)
> I just added my own icons (mostly from the Faenza icon set) using Tango as a
> base via the icon customization option (Tools -> Customize... -> Toolbars ->
> Modify -> Change Icon). The only way I could change the star icon was to
> manually switch out /res/savemodified_small.png in images_tango.zip with
> something else.

Oh I wasn't even aware that we have a GUI to exchange icons. So this is a problem, sure.
Any idea how to deal with this, Maxim?
Comment 7 Maxim Monastirsky 2016-02-28 23:19:32 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #6)
> Any idea how to deal with this, Maxim?
We can draw the star on top of the original save icon, like we do for color buttons, but I wonder how well it will fit with all icon themes.
Comment 8 Samuel Mehrbrodt (CIB) 2016-02-29 10:24:42 UTC
(In reply to Maxim Monastirsky from comment #7)
> (In reply to Samuel Mehrbrodt (CIB) from comment #6)
> > Any idea how to deal with this, Maxim?
> We can draw the star on top of the original save icon, like we do for color
> buttons, but I wonder how well it will fit with all icon themes.

Maybe do that only if no savemodified icon found in current icon theme?
Comment 9 Maxim Monastirsky 2016-02-29 15:03:10 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #8)
> Maybe do that only if no savemodified icon found in current icon theme?
How that will solve this particular bug?
Comment 10 Samuel Mehrbrodt (CIB) 2016-03-03 06:13:06 UTC
(In reply to Maxim Monastirsky from comment #9)
> (In reply to Samuel Mehrbrodt (CIB) from comment #8)
> > Maybe do that only if no savemodified icon found in current icon theme?
> How that will solve this particular bug?

Hm right, we would need to check whether the user has modified the icon and in this case draw the star on it.
Comment 11 QA Administrators 2017-05-22 13:20:24 UTC Comment hidden (obsolete)
Comment 12 mattia.b89 2019-02-02 22:06:43 UTC
Cannot reproduce the issue, in:

Version: 6.1.4.2
Build ID: 6.1.4-4
CPU threads: 4; OS: Linux 4.20; UI render: default; VCL: gtk3; 
Locale: it-IT (en_GB.UTF-8); Calc: group threaded
Comment 13 andreas_k 2019-04-24 20:48:40 UTC
as the user can select whatever "icon" the user want and this command need two icons (one for change and one for no change) I don't know how to easy solve this issue.

the "only" solution I see is to don't change the icon when the user define an specific icon for this (two) commands.

or set the bug to wfm.
Comment 14 Heiko Tietze 2019-04-25 11:05:59 UTC
Well spotted issue. My take here, we should accept the little shortcoming. Modifying the icon decoration was done intentionally and is effective. Solution could be to a) draw the decoration programmatically, b) have many icons in one icon file, c) split the button into different objects with different icons and hide contextually, and d) tweak the customization UI. All sounds like a lot of work for not much benefit.
Comment 15 andreas_k 2019-04-25 11:26:22 UTC
For me also a lot of work for less benefit
Comment 16 Heiko Tietze 2019-05-16 07:59:56 UTC
We discussed the issue in the design meeting. Possible solutions are:

 a) combine two/some icons in one with a proprietary format,
 b) split the UNO command into uno:SAVEEMPTY and uno:SAVEMODIFIED, 
 c1) draw the decoration programmatically, 
 c2) combine/overlay two icons

None of these are good solutions. And actually it's not common to change single icons so taking the effort of any patch into account it's not worth to do. => WF