Download it now!
Bug 98233 - Generic Icons for All LibreOffice Document Types
Summary: Generic Icons for All LibreOffice Document Types
Status: RESOLVED DUPLICATE of bug 98540
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86 (IA32) Mac OS X (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: MacOS-Wishlist
  Show dependency treegraph
 
Reported: 2016-02-27 16:11 UTC by drellft
Modified: 2016-04-09 16:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing generic icon. (31.47 KB, image/png)
2016-02-27 16:11 UTC, drellft
Details
screenshot (56.99 KB, image/png)
2016-02-29 01:29 UTC, Iandol
Details
Icon preview in Finder (47.31 KB, image/png)
2016-04-02 21:24 UTC, Yannick.D
Details

Note You need to log in before you can comment on or make changes to this bug.
Description drellft 2016-02-27 16:11:29 UTC
Created attachment 123042 [details]
Screenshot showing generic icon.

Documents associated with LibreOffice always appear with generic icons in the Finder of Mac OS X 10.11.3.

The .ICNS files in LibreOffice.app are never applied to these files.

Switching between list view and icon view makes no difference. Changing the icon size in icon view makes no difference. Please see attached screenshot.

Deleting and rebuilding the OS X icon cache does not help.

Icons for all other applications are correct.
Comment 1 Iandol 2016-02-29 01:29:37 UTC
Created attachment 123064 [details]
screenshot

I see this for ODT writer files, but not ods or odp, on OS X 10.11.4 public beta 4 and LO:

Version: 5.1.1.1
Build ID: c43cb650e9c145b181321ea547d38296db70f36e
CPU Threads: 8; OS Version: Mac OS X 10.11.4; UI Render: GL; 
Locale: en-GB (en.UTF-8)
Comment 2 Buovjaga 2016-03-21 18:38:56 UTC
NEW per comment 1.

Original reporter did not present evidence for ALL LibO types.
Please give a screenshot showing other types besides ODT having a generic icon.
If you cannot present the screenshot, change the summary of this report to be about ODT.
Comment 3 Yannick.D 2016-04-02 21:22:42 UTC
Can't reproduce. (LO 5.1.1.3 Vanilla App Store Version, OS X 10.11.3)

Screenshot provided by Iandol does not show a generic icon but an icon preview of the his (empty) document. See screenshot.

Version: 5.1.1.3 
Build-ID: f579d750e65277a91cbf19f00b90ad1b257718f9
CPU-Threats: 2; BS-Version: Mac OS X 10.11.3; UI-Render: GL; 
Gebietsschema: de-DE (de.UTF-8)
Comment 4 Yannick.D 2016-04-02 21:24:05 UTC
Created attachment 124034 [details]
Icon preview in Finder
Comment 5 Buovjaga 2016-04-03 10:41:10 UTC
Ok, sorry. Setting back to unconfirmed.
Comment 6 bbdmn 2016-04-09 16:29:15 UTC
It seems to me that it is the same issue as Bug 98540 - Info.plist seems to be broken in OS X

*** This bug has been marked as a duplicate of bug 98540 ***