Bug 98243 - cell scroll highlighting breaks cell border display when navigating up / down at document magnification of at least 150%
Summary: cell scroll highlighting breaks cell border display when navigating up / down...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.1.3 release
Hardware: All Mac OS X (All)
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Cell-Management
  Show dependency treegraph
 
Reported: 2016-02-27 21:56 UTC by steve -_-
Modified: 2018-04-07 21:11 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
screencast (554.54 KB, video/mp4)
2016-02-27 21:56 UTC, steve -_-
Details

Note You need to log in before you can comment on or make changes to this bug.
Description steve -_- 2016-02-27 21:56:48 UTC
Created attachment 123047 [details]
screencast

see attached screencast

the cell highlighting gets chopped up.

Version: 5.2.0.0.alpha0+
Build ID: 1bcccc175e6f2a884740436642056605ec15b92c
CPU Threads: 4; OS Version: Mac OS X 10.11.3; UI Render: GL; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-02-27_13:39:59
Locale: de-DE (de.UTF-8)
Comment 1 steve -_- 2016-02-27 21:58:07 UTC
This is identical if not using OpenGL (which I just enabled for fun to see if anything explosed - which it didn't)

Version: 5.2.0.0.alpha0+
Build ID: 1bcccc175e6f2a884740436642056605ec15b92c
CPU Threads: 4; OS Version: Mac OS X 10.11.3; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-02-27_13:39:59
Locale: de-DE (de.UTF-8)
Comment 2 Yousuf Philips (jay) (retired) 2016-02-27 22:03:16 UTC
Likely a mac only issue as doesnt happen on Linux.

Version: 5.2.0.0.alpha0+
Build ID: 003d0ccf902d2449320dd24119564565a384f365
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-23_02:42:33
Locale: en-US (en_US.UTF-8)
Comment 3 Yousuf Philips (jay) (retired) 2016-02-27 22:06:35 UTC
Hopefully one of the other mac users can verify this.
Comment 4 steve -_- 2016-02-27 22:12:28 UTC
Additional info: so OpenGL or default both have this issue.

This is ONLY happening in the first column.

Very odd finding: tested on a second mac (both 10.11.3) and there the issue was only on the second column.
Comment 5 Buovjaga 2016-02-28 15:19:42 UTC
Not seen on Windows in any column.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 85fcf15ff41ceb95f46dee586ff7187551be4955
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-27_09:23:38
Locale: fi-FI (fi_FI)
Comment 6 steve -_- 2016-06-06 11:12:46 UTC
Just another data point:

persisting with
Version: 5.3.0.0.alpha0+
Build ID: cbf36dd473fdc9e8d8b78c9e9317836a7cbbc6c7
CPU Threads: 4; OS Version: Mac OS X 10.11.5; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-06-01_00:32:05
Locale: de-DE (de.UTF-8)
Comment 7 Buovjaga 2016-06-06 11:34:23 UTC
Not seen.

Version: 5.3.0.0.alpha0+
Build ID: b2f994469f3e2f1fe72e9f103b840aa949ace6dd
CPU Threads: 4; OS Version: Mac OS X 10.11.5; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-05-25_23:36:03
Locale: en-US (en.UTF-8)
Comment 8 Alex Thurgood 2016-06-13 12:42:52 UTC
No repro 


Version: 5.3.0.0.alpha0+
Build ID: 90371480b5e8eab4f79a43faa216dec42ddafbb4
Threads CPU : 2; Version de l'OS :Mac OS X 10.11.5; UI Render : par défaut; 
Locale : fr-FR (fr.UTF-8)
Comment 9 Alex Thurgood 2016-06-13 12:43:39 UTC
Steve : what's your graphics chip ?
Comment 10 steve -_- 2016-06-13 19:08:38 UTC
imac: NVIDIA GeForce GTX 660M
macbook pro: Intel HD Graphics 3000
Comment 11 Alex Thurgood 2016-06-14 07:36:44 UTC
Mac mini : NVIDIA GeForce 320M 256 Mo
Comment 12 Alex Thurgood 2016-06-14 07:42:57 UTC
I can only reproduce this when I increase the document magnification to 150% or greater.

Version: 5.3.0.0.alpha0+
Build ID: ab7e112bcf2ecd09ea129ef81177df8036110cb6
Threads CPU : 2; Version de l'OS :Mac OS X 10.11.5; UI Render : par défaut; 
Locale : fr-FR (fr.UTF-8)
Comment 13 Alex Thurgood 2016-06-14 07:45:08 UTC
Changed title to better reflect behaviour
Comment 14 steve -_- 2016-06-14 08:16:15 UTC
Nice finding. For me, it is reproducible (always) at 140% zoom level (and higher).

Thanks for confirming.
Comment 15 Yousuf Philips (jay) (retired) 2016-06-14 22:28:22 UTC
Tried at various resolutions and still cant reproduce, so quite definitely a mac OS only issue.

@Steve, @Alex: Would be good to test if this is a regression by testing older versions. Regarding the title, did you guys confirm that this issue doesnt happen when navigation left and right?

Version: 5.2.0.0.beta1+
Build ID: 90e3e04841081b9c03ea54f1d5ca439a7a9ce1dd
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-5-2, Time: 2016-06-04_01:52:51
Locale: en-US (en_US.UTF-8)
Comment 16 steve -_- 2016-06-14 22:48:47 UTC
more findings:

* not happening for left - right navigation
* not happening for up - down navigation in other column row "A"

So issue required navigation to be in column "A".

Adding regression keyword, since this issue is not reproducible with LO 3.3 from https://downloadarchive.documentfoundation.org/libreoffice/old/3.3.0.4/mac/x86/
Comment 17 Yousuf Philips (jay) (retired) 2016-06-15 09:26:59 UTC
@steve: Can you test a few more recent versions, so we can better track down where it was introduced, like possibly 3.6, 4.2 and 4.4.
Comment 18 Xisco Faulí 2016-09-13 08:44:00 UTC
Adding keyword 'bibisectRequest'
Comment 19 Alex Thurgood 2017-07-31 10:53:26 UTC
Doesn't happen in


LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

or

Version 4.0.5.2 (Build ID: 5464147a081647a250913f19c0715bca595af2f)
Comment 20 Alex Thurgood 2017-07-31 11:07:14 UTC
No repro in

Version: 4.2.6.3
Build ID: 3fd416d4c6db7d3204c17ce57a1d70f6e531ee21

or

Version: 4.3.0.4
Build ID: 62ad5818884a2fc2e5780dd45466868d41009ec0

or

Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Locale: fr_FR

or

Version: 5.0.0.2
Build ID: a26d58f11b99b6aeddf7f7884effea188cc6e512
Locale: fr-FR (fr_FR.UTF-8)
Comment 21 Alex Thurgood 2017-07-31 11:10:47 UTC
Reproduced in

Version: 5.1.4.2
Build ID: f99d75f39f1c57ebdd7ffc5f42867c12031db97a
CPU Threads: 4; OS Version: Mac OS X 10.12.6; UI Render: default; 
Locale: fr-FR (fr_FR.UTF-8)
Comment 22 Alex Thurgood 2017-07-31 11:14:46 UTC
No repro either in 

Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: fr-FR (fr_FR.UTF-8)

so the problem was introduced with 5.1 branchoff somewhere.
Comment 23 Alex Thurgood 2017-07-31 11:25:36 UTC
No repro in

Version: 5.1.0.1
Build ID: bcace328aabc4c8c10b56daa87da0a2ee6579b5a
Threads 4; Ver: -; Render: default; 

Locale: fr-FR (fr_FR.UTF-8)
Comment 24 Alex Thurgood 2017-07-31 11:30:13 UTC
First introduced with 5.1.2

Version: 5.1.2.1
Build ID: 2603b69c5ec5981bb5f053f8ebfd1f3de00a4c29
CPU Threads: 4; OS Version: Mac OS X 10.12.6; UI Render: default; 
Locale: fr-FR (fr_FR.UTF-8)
Comment 25 Alex Thurgood 2017-07-31 11:42:30 UTC
Hmm, testing with

Version: 5.1.1.1
Build ID: c43cb650e9c145b181321ea547d38296db70f36e
CPU Threads: 4; OS Version: Mac OS X 10.12.6; UI Render: default; 
Locale: fr-FR (fr_FR.UTF-8)

shows that bug was already present there - resetting earliest version
Comment 26 steve -_- 2017-11-27 11:55:34 UTC
no longer reproducible. @alex / xisco: can you confirm this is fixed in master?

Version: 6.0.0.0.alpha1+
Build ID: 7a1c21e53fc4733a4bb52282ce0098fcc085ab0e
CPU threads: 4; OS: Mac OS X 10.13.1; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-11-23_06:01:54
Locale: de-DE (de_DE.UTF-8); Calc: group threaded
Comment 27 eisa01 2018-04-07 21:11:28 UTC
This works for me as well now, so resolving bug

Version: 6.1.0.0.alpha0+
Build ID: a488c7ad2763b944713997911c1ddb0315d8c93f
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2018-03-26_00:38:29
Locale: en-US (en_US.UTF-8); Calc: group