Bug 98267 - Cannot change position of outline numbering via Tools > Outline numbering... Position (file with specific settings)
Summary: Cannot change position of outline numbering via Tools > Outline numbering... ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chapter-Numbering-Dialog
  Show dependency treegraph
 
Reported: 2016-02-29 08:57 UTC by andis.lazdins
Modified: 2019-05-28 14:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
outline numbering example (8.77 KB, application/vnd.oasis.opendocument.text)
2016-02-29 08:57 UTC, andis.lazdins
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andis.lazdins 2016-02-29 08:57:32 UTC
Created attachment 123069 [details]
outline numbering example

Cannot change position and spacing parameters of outline (heading) numbering through Tools - Outline numbering dialogue.

Steps to repeat:
1. Open attached file
2. Click on Tools - Outline numbering
3. Select Position tab.
4. Change Aligned at: or any other numeric value to something else.
5. Click ok.
6. Click one more time on Tools - Outline numbering.
7. No changes appears in the default values (as well as in the document).

Normal behaviour - changed parameters affects position of numbering and changes persists in Outline numbering dialogue.
Comment 1 andis.lazdins 2016-03-08 15:10:18 UTC
Still there in 5.1.1.3, Ubuntu 14.04 32 bit
Comment 2 Buovjaga 2016-03-13 19:34:21 UTC
Change styles - List styles - Numbering 1. Then select all the numbering lines and double click the style Numbering 1. It applies.
Comment 3 andis.lazdins 2016-03-13 19:59:00 UTC
Thank you for recommendation!

Outline numbering can be changed also through Format > Bullets and Numbering... > Outline / Position / Options, but it was possible also through Tools > Outline numbering dialogue in previous versions.

I guess it is some kind of regressions / mistakes

The easiest way would be to remove Outline numbering... from Tools to avoid confusing situations.
Comment 4 Buovjaga 2016-03-13 20:01:03 UTC
Let's set to NEW and see what happens.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.0.0.alpha0+
Build ID: 235411c9d47ecba88e46d859ea93bcecefb0c46e
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on March 11th 2016
Comment 5 andis.lazdins 2016-04-01 05:20:04 UTC
The issue is still replicable in 5.1.2.2
Comment 6 Cor Nouws 2016-04-14 08:23:14 UTC
Hi,

This file is created with LibreOffice 5.1.1.2.
Opening in any version of LibreOffice that I have, one can't set the Alignment of the Outline numbering via the dialog. 
Now it must be done at paragraph (Style) level.
It has always be the other way round. From what I remember, that was expected.

Have to do more testing on how indent (paragraph) and alignment (heading or list style) combine..
Comment 7 QA Administrators 2017-05-22 13:26:45 UTC Comment hidden (obsolete)
Comment 8 Regina Henschel 2017-06-28 18:45:09 UTC
The problem is inside the file. It has a setting of left-margin="0cm" in the style. Go to the tab 'Indents & Spacing' of the paragraph style and click on button "Standard" to remove the settings. You might need to remove direct formatting too.

The behavior corresponds to the section 17.20<style:list-level-label-alignment> in the spec, where you read in the forth sentence,
"The fo:text-indent and fo:margin-left attributes are evaluated only for paragraphs inside list items whose paragraph styles do not specify them. If one of the two properties, or both, are specified by the paragraph style, the text indent and/or left margin are taken from the paragraph style. In this case the paragraph style's properties are used to determine the indent and margin for the text lines and thus also the alignment position."

After you remove the values, the settings of the Outline-Numbering-dialog will be mirrored to the paragraph style.

The entire handling is strange. So I will keep it as "New" and add it to the meta bug
Comment 9 QA Administrators 2019-05-28 02:47:32 UTC
Dear andis.lazdins,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug