Bug Hunting Session
Bug 98271 - Comment flyout does not clear block lines after auto hiding
Summary: Comment flyout does not clear block lines after auto hiding
Status: RESOLVED DUPLICATE of bug 73287
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-29 13:25 UTC by Clinton Wright
Modified: 2016-06-08 12:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Bug screenshots (273.42 KB, application/zip)
2016-02-29 13:25 UTC, Clinton Wright
Details
Spreadsheet to show bug (228.00 KB, application/vnd.ms-excel)
2016-03-03 06:35 UTC, Clinton Wright
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Clinton Wright 2016-02-29 13:25:18 UTC
Created attachment 123074 [details]
Bug screenshots

uname -r
4.1.17-1-lts

lsb_release -a

LSB Version:	1.4
Distributor ID:	Arch
Description:	Arch Linux
Release:	rolling
Codename:	n/a

LXQt window manager:
Version: 0.10.0

libreoffice --version

LibreOffice 4.4.7.2 40m0(Build:2)

Xorg config:

[root@HILT-CWRIGHT MAXreporting]# cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 340.76  (buildmeister@swio-display-x86-rhel47-01)  Thu Jan 22 12:12:24 PST 2015

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


Installed packages:

extra/libgnome 2.32.1-5 [installed]
extra/libgnome-data 2.32.1-5 [installed]
extra/libgnome-keyring 3.12.0-2 [installed]
extra/libgnomecanvas 2.30.3-3 [installed]
extra/libgnomeui 2.24.5-2 [installed]

extra/gnome-backgrounds 3.18.0-1 (gnome) [installed]
extra/gnome-calculator 3.18.3-1 (gnome) [installed]
extra/gnome-contacts 3.18.1-1 (gnome) [installed]
extra/gnome-desktop 1:3.18.2-1 (gnome) [installed]
extra/gnome-desktop2 2.32.1-3 [installed]
extra/gnome-dictionary 3.18.1-1 (gnome) [installed]
extra/gnome-disk-utility 3.18.3.1-1 (gnome) [installed]
extra/gnome-font-viewer 3.16.2-2 (gnome) [installed]
extra/gnome-icon-theme 3.12.0-3 [installed]
extra/gnome-icon-theme-symbolic 3.12.0-3 [installed]
extra/gnome-keyring 1:3.18.3-1 (gnome) [installed]
extra/gnome-mime-data 2.18.0-7 [installed]
extra/gnome-online-accounts 3.18.2.1-1 [installed]
extra/gnome-python 2.28.1-9 [installed]
extra/gnome-python-desktop 2.32.0-15 [installed]
extra/gnome-screenshot 3.18.0-1 (gnome) [installed]
extra/gnome-session 3.18.1.2-1 (gnome) [installed]
extra/gnome-settings-daemon 3.18.2-1 (gnome) [installed]
extra/gnome-system-log 3.9.90-1 (gnome) [installed]
extra/gnome-system-monitor 3.18.2-2 (gnome) [installed]
extra/gnome-terminal 3.18.2-1 (gnome) [installed]
extra/gnome-themes-standard 3.18.0-1 (gnome) [installed]
extra/gnome-tweak-tool 3.18.1-1 (gnome-extra) [installed]
extra/gnome-user-share 3.18.0-1 (gnome) [installed]

extra/xorg-xdm 1.1.11-6 [installed]
extra/xorg-server 1.18.1-3 (xorg) [installed: 1.18.0-4]
extra/xorg-server-common 1.18.1-3 (xorg) [installed: 1.18.0-4]

extra/icedtea-web 1.6.2-1 [installed: 1.6.1-1]
extra/java-commons-daemon 1.0.15-2 [installed]
extra/java-environment-common 2-2 [installed]
extra/java-jsvc 1.0.15-2 [installed]
extra/java-runtime-common 2-2 [installed]
extra/jdk7-openjdk 7.u95_2.6.4-1 [installed]
extra/jre7-openjdk 7.u95_2.6.4-1 [installed]
extra/jre7-openjdk-headless 7.u95_2.6.4-1 [installed]

extra/libvdpau 1.1.1-2 [installed]
extra/nvidia-340xx-lts 340.96-3 [installed: 340.96-2]
extra/nvidia-340xx-utils 340.96-1 [installed]
extra/xf86-video-nouveau 1.0.12-1 (xorg-drivers xorg) [installed]
community/libxnvctrl 352.21-1 [installed]
community/nvidia-cg-toolkit 3.1-3 [installed]
multilib/lib32-libvdpau 1.1.1-2 [installed]

Description:


Open calc document, create 4 - 5 columns of data which has at least 4 -5 rows, where the 3rd or 4th cell, for each column, has a comment. The comment must have
multiple lines of any random text, I put up to 10 lines of random characters.

Now, hover mouse cursor over the comment to make it appear, and after it appears,
move the cursor away from the cell to cause the comment flyout to hide itself.

This causes a part of the drawn comment to stay behind on the page and I have to scroll away from that part of the spreadsheet (the affected part needs to scrolled off page) to clear up the graphics.

See attached screenshots.

Any help to rectify this will be appreciated as I use this often and it is very frustrating as it makes parts of the spreadsheet unviewable and messy and I have to keep scrolling the page back, forth, up and down to clear the broken graphics.

Please let me know if there any other info I can send to help rectify this bug.

Many thanks,
Comment 1 Joel Madero 2016-03-02 20:28:04 UTC
Please attach an actual spreadsheet (simple) that we can use as a test case. Marking as NEEDINFO. Once you attach a spreadsheet mark as UNCONFIRMED. Thanks.
Comment 2 Clinton Wright 2016-03-03 06:35:40 UTC
Created attachment 123179 [details]
Spreadsheet to show bug

Hi,

Attached is a sample spreadsheet that I am able to use to constantly replicate the issue.

Many thanks
Comment 3 Clinton Wright 2016-03-03 06:37:41 UTC
Hi I have attached a sample spreadsheet as you have requested. Please test by hovering mouse cursor over comment fields (specifically Trucks Linked and Routes Linked). Do it right across the spreadsheet and you should see part of the flyout is not cleared properly when moving the cursor away from the hidden comment to make the flyout disappear.

Many thanks,
Comment 4 Buovjaga 2016-03-21 19:43:04 UTC
Reproduced. It took a bit of hovering. At first it can leave bits of the arrow head, so it might be hard to notice.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.0.0.alpha0+
Build ID: 4bf2b6b2e6641c82e2b714e394482f1a1620b436
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on March 21st 2016
Comment 5 Buovjaga 2016-06-08 12:57:20 UTC

*** This bug has been marked as a duplicate of bug 73287 ***