Bug 98342 - Enhancement: Use First N Characters of Document as Default Filename
Summary: Enhancement: Use First N Characters of Document as Default Filename
Status: RESOLVED DUPLICATE of bug 58685
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-02 09:59 UTC by Kevin Suo
Modified: 2016-06-06 12:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2016-03-02 09:59:55 UTC
Steps to Reproduce:
1. New Writer document;
2. Type in "abc"; type in a new paragraph "def".
3. Ctrl+S to open the save dialog.

--> Current behaviour: Default filename is "Untitled 1.odt".
Expected: It's better to use "abc.odt" as the filename. This is especially reasonable when the user set "Title" style for paragraph "abc".

MS Word is behaving in this way. In this way it takes the user little time to choose a reasonable filename, and avoid creating ""Untitled 1.odt", "Untitled 2.odt", "Untitled 3.odt"... files in daily life which is hard to identify.
Comment 1 Cor Nouws 2016-03-02 12:40:22 UTC
Hi Kevin,

This has been discussed not so long ago. (Stupid: can't find the issue :\ )
And the result was that we will keep the current behavior.
So sorry..
Comment 2 Adolfo Jayme 2016-03-02 18:51:36 UTC

*** This bug has been marked as a duplicate of bug 61053 ***
Comment 3 V Stuart Foote 2016-06-06 12:17:11 UTC

*** This bug has been marked as a duplicate of bug 58685 ***