Download it now!
Bug 98364 - Pop-up accent menu when Editing not available
Summary: Pop-up accent menu when Editing not available
Status: RESOLVED DUPLICATE of bug 42437
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All Mac OS X (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-02 21:10 UTC by Marc Grober
Modified: 2016-03-03 05:17 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Grober 2016-03-02 21:10:58 UTC
OSX provides an option to have a pop-up menu appear providing accented characters when a character is held down (as opposed to repeating the character.) This behavior is apparently not available in LibreOffice.  I posted to the users group to see if there was any intelligence available as to whether LO intentionally defeated this OS option or whether this was just incidental to some other aspect of the program and received no substantive responses.

So, the first question I have of course is whether there is some documentation of how LO changes the keyboard behavior on OSX, secondly, whether the behavior observed is consistent with the design of the software, and third, whether there is some reason that the OS is barred from managing this behavior and if not whether the OS behavior could be passed through.
Comment 1 Joel Madero 2016-03-02 21:27:38 UTC
This isn't the place for those questions. Go to the documentation mailing list to ask about documentation, the user mailing list about behavior. This isn't a support board - it's a bug reporting system. The fact that you didn't get the help you were looking for on the user ML doesn't change this. You can also ask on ask.libreoffice.org. 

Setting to INVALID.
Comment 2 Marc Grober 2016-03-02 21:34:02 UTC
The questions were posed and there were no responses, which does not mean that there is not a bug.

So, there is a bug AND there is lousy documentation AND pretentious admins

Before you mark this as NOT a bug demonstrate that it does not happen, or that is intentional.

Until then it is a bug :-)
Comment 3 Joel Madero 2016-03-02 21:47:20 UTC
@Italo - any thoughts on this ? Can you confirm it's a bug? Pinged you because I know you have access to OSX - I avoid it like the plague ;) Thanks!
Comment 4 V Stuart Foote 2016-03-03 03:49:31 UTC
This is a feature of OS X 10.7 (Lion) onward, and as the LibreOffice code base is primarily cross platform it is unreasonable to expect that all emerging Apple Cocoa NS widgets would be implemented natively in the LibreOffice core.

For this function LibreOffice provides the Special Character dialog to pick and insert special characters.  That is what the project is committed to.

Otherwise, a native OS X Cocoa developer would have to take an interest to code whichever NStext widget manages the PressAndHold.app to make it available in the LibreOffice builds.

There is no "intentional defeating this OS option", just the reality of cross platform support.

If you'd like to see more support for native OS X Cocoa widgets there are a number of developers that can support the development environment--you just have to give them incentive as to which to work on.
Comment 5 Adolfo Jayme 2016-03-03 04:46:21 UTC
I’ve got no idea why this was closed as NOTABUG — it *is* a bug, and this report a duplicate.

*** This bug has been marked as a duplicate of bug 42437 ***
Comment 6 Adolfo Jayme 2016-03-03 04:51:41 UTC
BTW, Stuart’s comment 4 is completely right on the spot.
Comment 7 V Stuart Foote 2016-03-03 05:17:40 UTC
> I’ve got no idea why this was closed as NOTABUG — it *is* a bug, and this
> report a duplicate.

Flipped a coin--change it to a feature request enhancement (which yes is technically a BZ tracked issue) or close it as NOTABUG--I opted to NOTABUG it. 

Comments on duplicate enhancement request bug 42437