Bug Hunting Session
Bug 98368 - Changed copy/paste MoveMode value
Summary: Changed copy/paste MoveMode value
Status: RESOLVED DUPLICATE of bug 97193
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-03 00:20 UTC by Doug Moore
Modified: 2016-03-15 14:32 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Doug Moore 2016-03-03 00:20:22 UTC
My macro for copy/paste was broken because the MoveMode value to InsertContents in overwrite mode changed from 4 to 6.
Before the update to LO 5, my using MoveMode value = 4 inserted contents in overwrite mode.  After the update to LO 5, MoveMode value = 4 inserts contents in insert mode!

Macro snippet:

dim argsPasteT(5) as new com.sun.star.beans.PropertyValue
	argsPasteT(0).Name = "Flags"
	argsPasteT(0).Value = "SVD"
	argsPasteT(1).Name = "FormulaCommand"
	argsPasteT(1).Value = 0
	argsPasteT(2).Name = "SkipEmptyCells"
	argsPasteT(2).Value = false
	argsPasteT(3).Name = "Transpose"
	argsPasteT(3).Value = true
	argsPasteT(4).Name = "AsLink"
	argsPasteT(4).Value = false
	argsPasteT(5).Name = "MoveMode"
	argsPasteT(5).Value = 6
	dispatcher.executeDispatch(document, ".uno:InsertContents", "", 0, argsPasteT())
rem---update to Libre Office v5.1 changed MoveMode value for overwrite from 4 to 6  ---no notification of this change!
Comment 1 Gitsy 2016-03-15 14:32:38 UTC

*** This bug has been marked as a duplicate of bug 97193 ***